1

I have successfully created a WiFi hotspot for my RPi 3B+ using a Hologram Nova and the embedded WiFi card on the Pi. However I realized that the ethernet interface has disappeared and cannot extend the hotspot to the Ethernet interface.

My setup is a mix of tutorials on how to create a hotspot but the main gist can be found here. I only changed the interface to be taken as the source the ppp0 instead of eth0.

Now I find myself needing to use the ethernet interface to plug a device that has no WiFi capabilities but does have the ethernet interface.

So my question is, how can I modify my hotspot to allow the dhcp server to serve the ethernet interface as well? I would like it to be dynamic as well so that I could potentially add an ethernet switch for more local devices.

Your help would be greatly appreciated!

As per your request, I ran:

ip --brief link show

result

And when I run

ifconfig

I get lo, ppp0 and wlan0 but no eth0.

Here is a screenshot of my current /etc/network/interfaces file

network/interfaces

  • "My setup is a mix of tutorials" - so how are we to know what you did! – Milliways Jul 9 at 3:41
  • What does it mean: "I realized that the ethernet interface has disappeared"? Do you find eth0 with ip --brief link show? What does it mean: "the interface to be taken as the source the ppp0 instead of eth0"? A source of what? Do you mean ppp0 is taken as an uplink to the internet router/modem/connection? – Ingo Jul 9 at 10:50
  • @Milliways, I did mentioned the only thing I did was that I changed the interface to be taken as the source ppp0 instead of eth0 – Agustin Jul 10 at 2:55
  • @Ingo, hello again, The interface doesn't show up when I do "ipconfig", please see the screenshot I have added on the question. – Agustin Jul 10 at 2:58
  • @Ingo, edit: "ifconfig" instead of ipconfig – Agustin Jul 10 at 3:22
1

On your installation you have predictable network interface names enabled so you will not always find classical interface names like eth0. Your wired interface has the name enxb827eb3f0e89. Instead of eth0 you have to use this name.

If you don't like predictable network interface names you can use sudo raspi-config to disable it with "2 Network Options -> N3 Network interface names". If it doesn't help you can edit /boot/cmdline.txt and add net.ifnames=0 to the line.

You can use the wired interface name (whatever name do you use) to configure either a routed or bridged interface. I suggest to use a bridge together with the wlan0 interface so all devices on wifi and wired are on the same subnet. I do not use deprecated ifupdown, managed with /etc/network/interfaces, since years so I cannot help much with this setup to create a bridge. I use systemd-networkd and do it this way: How can I set my pi 3 up to be WiFi AND ethernet router simultaneously?. In that setup I think you could just replace usb0 with ppp0.

  • Thank you kindly, I will check this when I get back from work. Will keep you posted – Agustin Jul 10 at 12:43
  • Okay, I have disabled predictable network interfaces names, I will go through your tutorial as well, however when I disabled the predictable network names, the auto boot from this post broke: raspberrypi.stackexchange.com/questions/100200/…... will add a timer for now see if that for now fixes it. – Agustin Jul 11 at 17:34
  • @Agustin or just use enxb827eb3f0e89 instead of eth0. – Ingo Jul 11 at 17:38
  • well i thought about that, but then wouldn't the correct way be to not use predictable network interface names? haha – Agustin Jul 11 at 17:43
  • @Agustin It's your decision what to use. It's nothing wrong with predictable names but I don't like this unmentionable names. If you switch you have to "repair" all other setups using an interface name. I always start my raspis from beginning with the option in cmdline.txt so I do not have a mix up. – Ingo Jul 11 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.