1

I've seen this post that describes the same problem I am facing, but the use case was somewhat different and the OP never updated the post with their solution.

I am attempting to run Synergy at boot, so that I can physically detach the keyboard and mouse all together from my Pi (3b+) and control it with my PC peripherals. I am fully aware of SSH, but this is how I wish to use it.

I've followed this tutorial to configure it, but it isn't working as expected. This is my autostart file located in /home/pi/.config/lxsession/LXDE-pi/:

@sh /home/pi/.startsynergy.sh

This is the contents of startsynergy.sh as per the tutorial:

#!/bin/bash
killall synergyc
sleep 1
synergyc --name pi 192.168.0.16
exit 0

After creating the autostart file and rebooting, I am presented with a black scree with only the cursor showing. I am able to do Ctrl + Alt + F1 to bring up the command prompt, and from there I can see that Synergy is in fact running from running ps -ef, and it successfully connects to my server (my PC). The issue is the fact that the GUI is completely absent, and therefore renders Synergy useless.

Any help is greatly appreciated, I've been trying to fix this for a couple of weeks now, and have read through lots of different forums and articles to no avail. Thanks!

2
  • Is 192.168.0.16 the correct IP in your case? Jul 10, 2019 at 6:45
  • 1
    No it's actually set to 192.168.1.54 on my Pi which is the address of the server. As I mentioned, it does connect to the server but the black screen is the issue, and the black screen only occurs when Synergy connects. Jul 10, 2019 at 8:59

1 Answer 1

1

If you have no luck with Synregy, perhaps you could try barrier. It is available via apt in Buster.

I tried out Synergy a while ago but it never really worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.