0

I have read several project instructions about how to use a Kindle Fire as a monitor for a Raspberry Pi. However, in my own attempts to imitate this I always have an issue because the Microsoft Remote Desktop app (xrdp) cannot access the pi on the network. This is frustrating as most directions describe this connection as simple and almost instantaneous. Any suggestions for a new Raspberry Pi user would be greatly appreciated.

Here is the relevant information. I have a Raspberry Pi B+, and I'm attempting to connect to a Kindle Fire HD (3rd generation).

I have downloaded Microsoft Remote Desktop 8.1.19.72 on the the Kindle. (I have also tried VNCClient.)

My username and password are the default pi/raspberry. This is confirmed because when I enabled the SSH it gave me a warning the change this.

The IP address according to "hostname -i" is 127.0.1.1. (One website suggested that I needed to use the local hostname and claimed that using ifconfig would show me this. After entering "ifconfig" 127.0.0.1 was listed next to "inet".)

There is a gateway option the Microsoft Remote Desktop App that I currently have turned off.

Several sources have claimed that the RealVNC that comes pre-loaded in the B+ Raspbian is the issue. On their advice, I loaded VNC4server and tightvncserver to "break" this; now VNC is "greyed out" in the Raspberry Pi Configuratioon Interfaces tab.

I have run sudo apt-get update and sudo apt-get upgrade.

I have removed xrdp, vnc4server and tightvncserver and then installed tightvncserver and then xrdp, in that order, because several have claimed that the installation order matters.

Finally, both the Kindle and Raspberry Pi are on and attached to the same wireless network.

I have tried to be exhaustive in figuring this out and documenting it, but I am afraid that there is still a rookie mistake in here somewhere. Any advice would be appreciated.

  • xrdp, tightvncserver and RealVNC are incompatible (in fact RealVNC disables the others) - pick one! RealVNC works to the RealVNC client on most platforms. – Milliways Jul 11 at 0:11
  • Thanks for the suggestion. I've disabled RealVNC and installed both tightvncserver and xrdp as numerous project sites recommend this. But I'll consider cleaning up my approach by just using one client. – snowka Jul 11 at 0:33
0

127.0.1.1 not reachable from your Kindle as it is a local address on your Raspberry Pi.

Check on your Raspberry Pi for the output of ifconfig. The relevant IP-address will be the one in the section of eth0 in case your Pi is connected to your LAN via Ethernet, or wlan0, if it is connected via WiFi.

Then try again with that address.

UPDATE:
As you state that you are not able to access the respective port on the Pi due to your LAN configuration, here is an alternative:

Setup your Raspberry Pi as WiFi access point and connect to it with your kindle.

  • Thanks for clarification on this. There was no IP address in the wlan0 field until I removed tightvncserver and used ReaVNC exclusively. Now it shows 192.168.1.162. However, when I use the RealVNC diagnostic self-test, it says that my Fios router is blocking the connection. It seems that this is in part a port forwarding issue, so I need to allow port forwarding to port 5900. Unfortunately, my router will not let me log into it, which is a separate complication. I hope that with this change made the VNC connection will be possible – snowka Jul 11 at 23:13
  • @snowka I have suggested a possible alternative in an update to my answer. – oh.dae.su Jul 12 at 6:51
  • Thanks for this suggestion. While I need to determine how to maintain internet access for the pi while it serves as a wi-fi access point that the kindle could access, this may be a better approach. – snowka Jul 12 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.