1

I'm running transmission-daemon on a Raspberry Pi running headless Raspbian. I can SSH into it fine, and the FTP server on it runs without a hitch, but I can't use the terminal interface for Transmission to control it. Running:

$ transmission-remote -m
$ transmission-remote localhost -m
$ sudo transmission-remote -m

All give the following error:

Unexpected response: 401: Unauthorized User: deflate, gzip

Any ideas? Or am I using the wrong command? I want to be able to see active torrents, add more, etc.

2

Transmission-daemon has a web interface.
If you want a pure command line interface, use transmission-cli
Otherwise if you want to use transmission-remote, you'll need to modify /etc/transmission-daemon/settings.json and modify this line -
"rpc-authentication-required": true, and make the true a false

  • I changed "rpc-authentication-required": true to false, restarted the server, and I still can't connect or see server stats. – Ian Hyzy Oct 12 '13 at 1:07
  • transmission-daemon is a bit funny, If you restart the server, it will overwrite the configuration file. After you modify the configuration file, run this command - killall -HUP transmission-daemon – Lawrence Oct 14 '13 at 1:40
  • I'm still getting the error and I checked to make sure the config file is persisting. – Ian Hyzy Oct 15 '13 at 1:22
  • Can you paste the config file somewhere ? – Lawrence Oct 15 '13 at 1:58
  • I tried re-installing and following all the instructions again and it works now, but there's no authentication. If someone has my IP address, couldn't they use transmission? – Ian Hyzy Oct 15 '13 at 4:14
0

If you want to keep "rpc-authentication-required": true for security reasons, you can supply the username and password with the auth flag, e.g. transmission-daemon -m --auth username:password.

It's quite possible that the server could be reachable by others, depending on how things are setup. I would recommend keeping auth on if you're not sure - it can't hurt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.