2

I just downloaded raspbian from raspberrypi.org/downloads, and I cannot unzip the archive. (I am using ubuntu 12.04)

Archive Manager says:

7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
p7zip Version 9.20 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,2 CPUs)

Error: /home/homie/Downloads/NOOBS_v1_3.zip: Can not open file  as archive

Errors: 1

and unzip complains that

Archive:  Downloads/2013-09-25-wheezy-raspbian.zip
End-of-central-directory signature not found.  Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive.  In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of Downloads/2013-09-25-wheezy-  raspbian.zip or
     Downloads/2013-09-25-wheezy-raspbian.zip.zip, and cannot find 
     Downloads/2013-09-25-wheezy-raspbian.zip.ZIP, period.

I've tried the same with NOOBS_v1_3.zip, with the same result.

Edit: I checked the shasums, and they don't match. So apparently the files are corrupted.

  • Corrupt file. If you try to open in Windows, Mac or Linux IDE can you read it? If not - redownload it. You seem to have answered your own question. You can write your own answer (below) and describe how you did crc-check and how you managed to determine it was corrupt. It might help others. Otherwise it is likely it will get closed. Thanks – Piotr Kula Oct 11 '13 at 11:44
  • Use 'file' command to get information about file is completed or not. If you didn't get information about zip file, it is corrupted. Example : gurcan@stats ~$ file VMWare.zip VMWare.zip: Zip archive data, at least v2.0 to extract – gurcanozturk Oct 11 '13 at 13:46
  • I have it working now (after re-downloading it more than ten times..). Arne describes how to check the files in his answer. – florian Oct 11 '13 at 14:48
  • I checked, and the 'file' command gave the same output for the zip files with matching sha-1 sums as it gave for the ones without matching sha-1 sums. – florian Oct 11 '13 at 14:51
  • This is a question about zipping/unzipping files (and ultimately about corrupt files). The fact that it pertains to a Raspberry Pi file does not make it on-topic for this site, which focuses on problems specific to Raspberry Pi devices. – ramblinjan Oct 24 '13 at 6:49
1

In the download folder of Raspbian, you can find an SHA1 checksum for the zip-archive:

99e6b5e6b8cfbf66e34437a74022fcf9744ccb1d  /var/www/raspbian/images/raspbian-2013-10-07/2013-09-25-wheezy-raspbian.zip

Please run sha1sum 2013-09-25-wheezy-raspbian.zip and compare the output with the above checksum, or rather the checksum corresponding to your file. It will most probably not match. Then you should re-download. You can easily use wget to fetch Raspbian:

wget http://downloads.raspberrypi.org/raspbian_latest
  • This is exactly what I did. After re-trying a couple of times it now works (correct checksum & the file unzips without problems). – florian Oct 11 '13 at 14:45
  • use wget with "-c" parameter to resume. – gurcanozturk Oct 11 '13 at 15:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.