I have a Raspberry Pi B which is running Raspbian Buster (installed through NOOBS). I am trying to run Minecraft on it. I have downloaded the Pi version of Minecraft from the Minecraft website, unzipped it and am running ./minecraft-pi in the mcpi directory. I am getting the following error

./minecraft-pi: error while loading shared libraries: libGLESv2.so: cannot open shared object file: no such file or directory

I have done a bit of Googling and have tried

  • sudo apt-get install libgles2
  • Uninstalling, cleaning, and reinstalling python-pygame
  • Running LD_LIBRARY_PATH=/opt/vc/lib ./minecraft-pi (I have looked in the /opt/vc/lib directory and can see libGLESv2_static.a but no libGLESv2.so)
  • Navigating to the minecraft-pi file in the GUI desktop and choosing execute from the menu

None of the above have worked and I'm now stumped. My LINUX knowledge is still in its infancy so please keep answers simple or with an explanation.

  • 2
    The Pi version should be installable from 'Preferences','Recommended Software'
    – CoderMike
    Jul 13, 2019 at 15:28

2 Answers 2


Run this command:

sudo apt update
sudo apt install -y minecraft-pi

Or install via the main menu (Preferences -> Recommended Software -> Games) as @CoderMike mentioned.

Downloading minecraft-pi-0.1.1.tar.gz directly provided most of what's needed but it doesn't include all dependencies, which APT takes care of.

  • Trying to install via terminal gives me Unable to locate package minecraft-pi. Using Buster released 2020-02-12
    – maafk
    Sep 27, 2020 at 22:07
  • That could mean your package definitions are out of date. I have edited my answer to include sudo apt update. Multiple sources report minecraft-pi is still available in the Raspbian repositories.
    – jdonald
    Nov 14, 2020 at 13:48
  • On the May 23, 2023 version of Buster, after sudo apt update, the install attempt still reports "unable to locate." It's also not in "recommended software."
    – Bob Brown
    Nov 3, 2023 at 19:03

The latest version of Minecraft (java) that can be played on 32bit Raspbian Buster is 1.12.2

Here is my tutorial:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.