2

I have a TP-LINK TL-WN725N for my RPi, but it doesn't work out of the box. Atleast I can't connect to wifi. I've tried 'Isusb' but don't see it, I don't see my keyboard either though so I might do something wrong.

Can I just drag and drop the drivers to a usb from my windows to the RPi? How do I install it?

1

I have a TP-LINK TL-WN725N for my RPi, but it doesn't work out of the box.

I have a TP-LINK TL-WN725N for my RPi, and it does work out of the box.

I've tried 'lsusb' but don't see it

It will be listed like this:

Bus NNN Device NNN: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN

Since it identifies itself by chip manufacturer and model number. Beware that if you plug this dongle in while the pi is running, it will kill the power momentarily -- causing an unclean shutdown and a reboot. So don't do that, it could lead to grief. Plug it in before you boot or use a hub. Unplugging it is okay.

The driver for this is the 8192cu driver, which should be bundled with the kernel whatever distro you are using. While it's plugged in, try lsmod | grep 8192 and you should see it listed. If so, the dongle has been detected and is ready to use, try iwconfig and you should see somewhere in there:

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"

If not, try modprobe 8192cu and see what that says (if it says nothing, run lsmod again and check).

In my experience, the dongle runs a bit glitchy on the pi -- used on another linux system with the same driver, it's fine, but on the pi it seems to drop the connection occasionally. Also, on the other system the little blue led inside stays on -- on the pi it blinks. However, if your software compensates for the occasionally disconnect, it is not noticeable and works fine.

Atleast I can't connect to wifi.

That's a whole other issue, then. If you want more specific help, you'll have to post another question explaining what you've tried and where it failed. It won't happen automatically.

Can I just drag and drop the drivers to a usb from my windows to the RPi?

Not a chance. Unfortunately, most manufacturers do not support linux and so other people have to write the drivers, which is why there is not necessarily a perfect one for every device. WRT the rpi specifically, if you are buying stuff for use with it, check the verified peripherals page. The wifi adapters have a page of their own linked in that one, and if you check that page you'll see a couple of (slightly conflicting) reports about the TL-WN725N...I would not trust the one about "manual driver installation" as this person seems to have made an incorrect assumption about what model numbers correlate to what driver.

  • In my case I can't find it, but I'm a total linux noob. Now when I do Isusb thats all I write, am I missing something because I get bash: Isusb: command not found. Im doing it in desktop directory if that matters. Before I can start troubleshooting the wifi I need to know the dongle is working. And about dragging and dropping the drivers I was ofc referring to the working linux drivers, since I have no connection on the pi (not even LAN) that's all I could think about. – justanotherhobbyist Oct 11 '13 at 17:10
  • You should be more explicit when you ask a question to save yourself and everyone else some time. I can't at every point go off for a few paragraphs, "If you meant this..." and/or "If this is such and such..." and/or "To determine whatever..." etc. That's an infinite regress. In this case you are missing lsusb, which is not at all the same thing as saying "lsusb doesn't show whatever" -- lsusb didn't show anything because you didn't have it installed. dpkg -S lsusb will point you toward apt-get install usbutils. – goldilocks Oct 11 '13 at 17:56
  • So by "more explicit" I mean you should post the actual output of a command you feel has failed. Something I should have asked for to start with, I guess. – goldilocks Oct 11 '13 at 17:58
  • dkpg -S Isusb gave the same "command not found" so I did apt-get.. and I'm not root, how do I get root access? And I know what you mean about giving all details, but I'm such a noob that I don't even know what the details are. Sorry. – justanotherhobbyist Oct 11 '13 at 18:05
  • Hmmph -- I would have thought dpkg was part of the core install. But you can add that with apt-get install dpkg. WRT root access, you can use sudo (which may require some configuration to work), or su, for which you must know the root password created when you first booted the system. You can also exit (if you are logged in non-remotely) and log in again or just plain login, but these require the password too. – goldilocks Oct 11 '13 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.