1

Recently I have attempted to install Arch Linux on my Raspberry Pi 3B for a small project. After installation of the OS according to https://archlinuxarm.org/platforms/armv8/broadcom/raspberry-pi-3, the text on my monitor was overflowing. I attempted to fix this by editing the FAT32 partition's config.txt file by adding the following lines:

overscan_left=10
overscan_right=10
overscan_top=30
overscan_bottom=30

However this caused my entire screen to become slanted diagonally, making the text on it completely illegible. I also attempted

disable_overscan=1

But this simply reverted the system to the original overflowing problem. In a troubleshooting attempt I then tried

overflow_left=1

This resulted in the entire screen appearing essentially in italics.

I have no clue what is going on here and have as yet been unable to find any documentation online regarding the problem.

Here are my specifications: Model: Raspberry Pi 3B V1.2
OS: Arch Linux Latest RPi 3 from http://os.archlinuxarm.org/os/ArchLinuxARM-rpi-3-latest.tar.gz
OS Installing From: Ubuntu 18.04 LTS

Also, I don't know if it's important but in the config.txt file there is also this line (there at the start)

enable_uart=1

I believe this fixes a RasPi 3 bug in the display (this might affect something??). However, removing this line doesn't seem to change anything.

Any help would be greatly appreciated.

0

Okay, I fixed it. Apparently, my (very old) Sony Bravia monitor was the problem. Having tried it on a newer monitor, the whole thing works perfectly.

No settings changes were needed on the Pi. Same cables, different monitor.

I hope this helps someone!

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Dec 16 '19 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.