2

I have been trying to launch Kodi on my Raspbian Buster.

I did a fresh install of Raspbian Buster Lite and then installed Kodi.

sudo apt install kodi

As I don't need the GUI I think I just have to manually install a few dependencies for running Kodi as the only UI required app.

I followed the instruction here https://www.raspberrypi.org/forums/viewtopic.php?t=192499 with a small adjustment to the location of the kodi.service to put it in /etc instead of /lib as they mention here.

Tried all following ways to launch Kodi.

kodi
kodi-standalone
sudo systemctl start kodi

All of them fail with same error. As people are saying there is no xserver required I anyhow tried installing xserver, but it still gives me same error.

Is there any expert out there who knows how to solve or point me in right direction?

On my previous Raspbian Stretch all was working fine, but don't recall if I did anything special 2 years ago, to make this work.

$ cat kodi_crashlog-20190715_212803.log
############## Kodi CRASH LOG ###############

################ SYSTEM INFO ################
 Date: Mon 15 Jul 21:28:03 BST 2019
 Kodi Options:
 Arch: armv7l
 Kernel: Linux 4.19.57-v7+ #1244 SMP Thu Jul 4 18:45:25 BST 2019
 Release: Raspbian GNU/Linux 10 (buster)
############## END SYSTEM INFO ##############

############### STACK TRACE #################
############# END STACK TRACE ###############

################# LOG FILE ##################

21:27:33.630 T:1831238192  NOTICE: special://profile/ is mapped to: special://masterprofile/
21:27:33.631 T:1831238192  NOTICE: -----------------------------------------------------------------------
21:27:33.631 T:1831238192  NOTICE: Starting Kodi from Debian (17.6 Debian package version: 2:17.6+dfsg1-4+b1). Platform: Linux ARM 32-bit
21:27:33.631 T:1831238192  NOTICE: Using Release Kodi from Debian x32 build
21:27:33.631 T:1831238192  NOTICE: Kodi from Debian compiled from 2:17.6+dfsg1-4+b1 by GCC 8.2.0 for Linux ARM 32-bit version 4.18.20 (266772)
21:27:33.631 T:1831238192  NOTICE: Running on Raspbian GNU/Linux 10 (buster), kernel: Linux ARM 32-bit version 4.19.57-v7+
21:27:33.631 T:1831238192  NOTICE: FFmpeg version/source: 4.1.3-1+rpt1
21:27:33.631 T:1831238192  NOTICE: Host CPU: ARMv7 Processor rev 4 (v7l), 4 cores available
21:27:33.631 T:1831238192  NOTICE: ARM Features: Neon disabled
21:27:33.631 T:1831238192  NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
21:27:33.631 T:1831238192  NOTICE: special://xbmcbin/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi
21:27:33.631 T:1831238192  NOTICE: special://xbmcbinaddons/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi/addons
21:27:33.631 T:1831238192  NOTICE: special://masterprofile/ is mapped to: /home/pi/.kodi/userdata
21:27:33.631 T:1831238192  NOTICE: special://envhome/ is mapped to: /home/pi
21:27:33.631 T:1831238192  NOTICE: special://home/ is mapped to: /home/pi/.kodi
21:27:33.631 T:1831238192  NOTICE: special://temp/ is mapped to: /home/pi/.kodi/temp
21:27:33.631 T:1831238192  NOTICE: special://logpath/ is mapped to: /home/pi/.kodi/temp
21:27:33.631 T:1831238192  NOTICE: The executable running is: /usr/lib/arm-linux-gnueabihf/kodi/kodi.bin
21:27:33.631 T:1831238192  NOTICE: Local hostname: raspberrypi
21:27:33.631 T:1831238192  NOTICE: Log File is located: /home/pi/.kodi/temp//kodi.log
21:27:33.631 T:1831238192  NOTICE: -----------------------------------------------------------------------
21:27:33.637 T:1831238192   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
21:27:33.701 T:1831238192  NOTICE: load settings...
21:27:33.743 T:1831238192   ERROR: PulseAudio: Failed to connect context
21:27:33.743 T:1831238192  NOTICE: PulseAudio might not be running. Context was not created.
21:27:33.777 T:1831238192  NOTICE: Found 1 Lists of Devices
21:27:33.777 T:1831238192  NOTICE: Enumerated ALSA devices:
21:27:33.777 T:1831238192  NOTICE:     Device 1
21:27:33.778 T:1831238192  NOTICE:         m_deviceName      : @
21:27:33.778 T:1831238192  NOTICE:         m_displayName     : Default (bcm2835 ALSA bcm2835 ALSA)
21:27:33.778 T:1831238192  NOTICE:         m_displayNameExtra:
21:27:33.778 T:1831238192  NOTICE:         m_deviceType      : AE_DEVTYPE_PCM
21:27:33.778 T:1831238192  NOTICE:         m_channels        : FL,FR
21:27:33.778 T:1831238192  NOTICE:         m_sampleRates     : 8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000
21:27:33.778 T:1831238192  NOTICE:         m_dataFormats     : AE_FMT_S16NE,AE_FMT_S16LE,AE_FMT_U8
21:27:33.778 T:1831238192  NOTICE:         m_streamTypes     : No passthrough capabilities
21:27:33.788 T:1831238192  NOTICE: No settings file to load (special://xbmc/system/advancedsettings.xml)
21:27:33.788 T:1831238192  NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
21:27:33.788 T:1831238192  NOTICE: Default Video Player: VideoPlayer
21:27:33.788 T:1831238192  NOTICE: Default Audio Player: paplayer
21:27:33.788 T:1831238192  NOTICE: Disabled debug logging due to GUI setting. Level 0.
21:27:33.788 T:1831238192  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
21:27:33.789 T:1831238192  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
21:27:33.789 T:1831238192  NOTICE: Loaded playercorefactory configuration
21:27:33.789 T:1831238192  NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
21:27:33.789 T:1831238192  NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
21:27:33.806 T:1831238192  NOTICE: Running database version Addons27
21:27:33.856 T:1831238192  NOTICE: ADDONS: Using repository repository.xbmc.org
21:27:33.905 T:1831238192   ERROR: X11 Error: No Display found
21:27:33.905 T:1831238192   FATAL: CApplication::Create: Unable to init windowing system


############### END LOG FILE ################

############ END Kodi CRASH LOG #############
  • You're out of luck. The version of Kodi in Raspbian Buster does not work. It uses EGL & GLESv2 and those aren't in Buster. – Dougie Jul 17 at 20:57
  • @Dougie But Kodi is in the default repository. Do you think the maintainer have put it in there without the ability to run on buster? – Ingo Jul 18 at 18:45
  • @Ingo Correct, it is Kodi 17 on buster and Kodi 18 on stretch. However on buster it seems some GUI libs are missing to be able to run GUI apps. so it might not be related to just Kodi. Kodi 17 on stretch worked perfectly also. – Marco Franssen Jul 19 at 11:49
  • @ingo I know it's broken because I've spent hours beating it into submission on my 3B+ and 3A+ systems. I reverted the 3B+ to Stretch. – Dougie Jul 19 at 19:49
1

As some of you already commented in the comments Raspberry Buster has some issues running Kodi.

I decided to downgrade to Raspbian Stretch and captured all my steps in some blogpost.

This first part is about how to reinstall Raspbian in a quick and easy way.

https://marcofranssen.nl/install-fresh-raspbian-image-on-your-raspberry-pi-part-1/

The second part shows how to install Kodi, ensure it boots automatically and is running in a secure way under a separate user with limited rights. Please check out the blogpost for all details, tips and tricks.

https://marcofranssen.nl/install-fresh-raspbian-image-on-your-raspberry-pi-part-2/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.