8

I have an RPI4 running a Plex server, Pihole, etc etc.

Power kept dropping while running certain tasks involving the attached HDD, so I started using a powered USB3 hub - problem solved.

But now the Pi won't boot with the powered USB hub attached. I have to unplug it, wait for boot, then plug it back in.

What am I missing?

2
  • I think I saw a note about this in the Raspberry Pi forums. You might want to check there for the latest updates on this issue.
    – bls
    Jul 16, 2019 at 16:10
  • what is the power rating of the power supply you are using? I think it is some sort of booting problem or power surge problem May 18, 2020 at 21:32

10 Answers 10

5

The issue could stem from the fact that some cheap USB hubs back-power an unpowered host when those hubs are powered: essentially, the 5V circuit of the hub is directly connected to the 5V line of the upstream USB port, allowing the current from to hub to power the Pi. The Pi 4 requires a power cycle to reboot on some bootloader settings (POWER_OFF_ON_HALT=1?), and if the power keeps coming via a USB port, that might prevent the power chip from resetting the system properly, so it hangs until all power is unplugged.

Buying a compliant USB hub is the right solution. A hacky alternative I use is described here: if you have an oversized power supply, you can bypass the current limitation of the USB ports, which allows you to plug in more power-hungry USB devices without a hub.

3

Had the same powered usb hub issues with my pi4. If connected to pi + hdd+ power ----pi hangs. If connected to pi + no HDD + power --- pi hangs / does not boot. Note in the above cases pi was headless. Went for the expensive option and bought:

UGREEN USB 3.0 Hub Ethernet Adapter 10/100/1000 Gigabit Network Converter with USB 3.0 Hub 3 Ports And the recommended power adapter:

UGREEN 5V 2A Power Adapter AC 100-240V to DC 5V Transformers PSU Replacement Power Supply Cable Wall Charger UK Plug with 1.5m Lead,3.5mm Plug for Led

All from Amazon

Problem solved 🤗

Noted the issue had nothing to do with the editing of my /etc/fstab file.

https://www.amazon.co.uk/gp/product/B00LLUEJFU/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1

https://www.amazon.co.uk/gp/product/B00TAILRR8/ref=ppx_od_dt_b_asin_title_s00?ie=UTF8&psc=1

Thank you all!

1
  • The Pi 4 asks for 3A which is really hard to come by, this USB hub didn't specify the maximum power rating on the ports make me a little bit worried.
    – Vicary
    Dec 24, 2020 at 7:41
2

You have to make sure that you are getting consistent 5V from the USB hub, and at the very least 1 Amp in current... most usb hubs will only regulate to 500 mA which sounds like what you were getting due to the power drops. Did you see a lightning bolt on the screen when working on the Pi either on commandline mode or Desktop? If you did, you got your answer :)

4
  • I'll see if I can find out what the hub is doing with power, as I suspect you're correct - however I haven't once seen the lightning bolt!
    – lukenm
    Jul 17, 2019 at 9:12
  • why did you downvote? It’s a perfectly good possibility and it happens all the time. If this was not the case this time, you didn’t have to downvote just mention in the comments it wasn’t your case. :(
    – Agustin
    Jul 17, 2019 at 14:20
  • I didn't downvote! In fact, I upvoted. You're absolutely right, that was a correct answer but not quite in this instance.
    – lukenm
    Jul 17, 2019 at 16:25
  • Aww thanks, I guess someone is trolling around
    – Agustin
    Jul 17, 2019 at 16:25
2

I found the exact same issue in a Reddit post and the solution seems to be a frustrating one - find a more expensive powered USB hub. Oh well.

2

tldr; .. Chain it with an unpowered hub in between.


I had this problem, too. I believe I found a tenable solution. I happened to have a spare Ankur unpowered hub that I thought maybe could take the load of power off the powered hub's host plug. It worked! sudo reboot brought me right back up again, with my powered hub still seen and working.

Connect the USB host plug of the powered USB hub into the port of the otherwise empty unpowered USB hub, and plug the host plug of the unpowered USB hub into the Raspberry Pi. In my case I had:

While I did not check that the powered USB hub's performance was USB 3 speeds, I did run

lsusb -t

.. and validated that my external hard drive connected to the powered USB hub was connected on a "5000M" port rather than a "480M" port.

0

I find that a better solution was to attach the USB power adapter to a smart adapter e.g TP 100 (Tapo)

In this way I can also use a cheap USB3 powered Hub - the Ugreen was not 100% consistent

Now when I reboot the Pi4 , I just power-cycle the USB hub through the internet and presto the Pi4 does its normal stuff.

This is 100% consistent- albeit at the moment. Then again the foundation still have to resolve this Pi4 USB issue - the pi3 has no such issues!!!!!

0

The issue is potentially as Dmitry Grigoryev says, that some powered hubs "back power" the host.

I tried first using a schottkey diode between the power to the hub and the hub but this didn't help. I decided to see what happened with the red removed altogether. This still didn't help either.

I can't recall all the details off the top of my head but part of how USB works involves the hub pulling up USB data lines at times and it seems this is either enough to allow a voltage to then leak back to the power rails the RPi PMIC is checking, or that the problem is in fact slightly different and somehow caused by the presence of a USB hub at boot confusing the bootloader. In either case the solution I came up with was a simple modification to the hub using a few bits out the parts bin and 10 minutes with the soldering iron. I found

  • an NPN transistor,
  • a P channel MOSFET (grossly over-rated at 61 Amps, but that's what I had to hand)
  • and a couple of 4k7 resistors.

The VBus signal (red wire) from the host connects to the base of the transistor via a 4k7 resistor. The Emitter is connected to GND (black wire from host). The Source of the FET connects to the external power source in (which is isolated from the hub), and the Drain to the hubs power rail. The collector of the transistor is connected to the gate of the FET such that it is pulled down when the host provides power, thus switching on the FET and powering the hub. The remaining 4k7 resistor between the Power source and the gate prevents it floating around. Finally I put the Schottky diode back in place such that the hub can still be used without external power.

My rpi4 now boots perfectly every time (from LAN) and with a USB DVD drive connected, something the previous rpi3 wouldn't do.

0

I use the following USB Hub: https://www.aliexpress.com/item/1005003503837167.html I disassembled and disconnected the VBUS (red) wire. Since then it has been working perfectly, no problems when booting too.

0

HERE'S AN INSTANT WORKAROUND FROM A 3rd WORLD COUNTRY WHICH IS ACTIVELY BEING SUNK.

USB3 pinout: https://pinoutguide.com/Slots/usb_3_0_connector_pinout.shtml

=====> I've prevented contact on pin 4 (GND) with a paper strip, careful not to prevent contact on other pins, especially pins 5-6, deeper in the connector.

Of course I'm talking about the USB connector which comes from the HUB and gets plugged into one of the Raspberry PI4 USB3 port.

Hypothesis: The signal lines have their own circuit, so interrupting either + or - of the power circuit (pins 1 and 4) shouldn't impede comms.

It works, boot/reboot fine, speed hasn't changed and it's OK for USB3.

On the other side of the cable I have a generic cheap powered USB3 HUB (small and fast, 4 ports, each one has a switch 0-1, I can't see any brand name, only "model ASX407" on a label added by the importer, I've bought the last two the seller had in stock and still I've spent about half of what I would have spent to buy one Transcend TS-HUB3K from abroad).

I'VE USED THE THINNEST PAPER I HAD HANDY, it turned out to be an ad deposited into my mailbox, I've cut a strip about as wide as one contact of a Yubikey 5 NFC (USB B), 2-3 cm long, I've put 4-5 mm of it into the connector, covering pin 4, and I've bent the rest on the connector chassis itself.

IMPORTANT NOTE: I haven't inserted the strip to the bottom of the connector, only 4-5 mm, then I've plugged the connector into the Raspberry PI4, which keeps the paper strip from moving (despite the fact that I have a fan pointing to it).

I was expecting to have to do multiple trials but it worked at the first one, I can now boot/reboot without having to temporarily disconnect the HUB power source, SPEED IS NOT LESS THAN BEFORE.

(The local market does not offer any of the HUB models with which there's no problem at boot/reboot time, buying abroad is being made more and more problematic, no commerce => plenty of activities die, it's NWO-ish, it's OFF-TOPIC though.)


MARGINAL NOTE:

This PI4's firmware is up to date.

Before the last update, this HUB was NOT giving I/O errors, but this WD Elements 4TB disk was, if connected directly to the PI4.

After the last update, on the contrary, I can also connect the disk directly to the PI4 without I/O errors (and I'm not getting low tension alerts any more, but still I prefer to power the disk from the HUB instead of having that current flow through the PI4).

When was the previous firmware update? A couple of years ago, I've let this thing sleep for some time (I had enough of wasting time looking for something which would not give these I/O errors on the picky USB3 port, with its makers apparently unwilling to publish any list of compatible devices and even closing the related GitHub thread which was full of hints by PI4 users [and complaints for the makers attitude]... recently I've told to myself that by now those problems could have been fixed by new kernel/firmware releases).

-2

Right from the Raspberry Pi 4 page

Get started
You will need
- A 15W USB-C power supply – we recommend the official Raspberry Pi USB-C Power Supply

15 watts is a lot more than a typical USB hub must provide, see also Wikipedia - USB - Power

1
  • 1
    There sre lot more other problems . only following this is not going to solve the problem May 18, 2020 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.