5

I have been trying to use Alexa on my Raspberry Pi 3 B+ (running Stretch). I ran Alexa successfully, with a USB microphone and a speaker connected through the 3.5mm jack, about a week ago and went on to make a python program that does not in any way tamper with the 3.5mm jack or the audio driver. Today I started Alexa again and there was no audio output. I connected to the Pi through VNC and found that the sound icon on the top right of the screen is muted. I clicked the icon and the drop down menu says "No volume control on this device." I would like to know the cause and solution of this issue. I have searched for solutions through Bing but had no luck.

5

Also check the /boot/config.txt file. It should look like this:

# Enable audio (loads snd_bcm2835)
dtparam=audio=on 
  • That worked perfectly. Thank you very much. Is there somewhere I can find a default config.txt. I am afraid that I messed mine up – Yuxi L Jul 17 at 12:47
  • Each config.txt is unique to the version of the Pi your using, the firmware, and the version of OS. I'm not sure its easy to find the exact one for your config short of a fresh install. FWIW: Raspi-config typically adds the changes at the end of the file. – tbitson Jul 18 at 1:58
  • 3
    dpkg -S /boot/config.txt; apt reinstall <the result of dpkg -S> – Yet Another User Jul 18 at 6:56
5

I suggest you run raspi-config, look at Advanced Options>Audio and make sure the "1 Force 3.5mm ('headphone') jack" option is selected.

Then reboot...

  • 1
    It throws out the error There was an error running option A4 audio, and tbitson's answer solved my problem. Thank you for your suggestion! – Yuxi L Jul 17 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.