1

I setup Rasbian on a 32GB sd card and inserted it into Raspberry Pi 3 Model B(V1.2). When I swtch on the Raspberry Pi, It's boot stuck at rc-local.service. First I tried Rasbian. I flashed the image without any modifications. Then I erased SD card and put a Windows IoT image.

It get power from a power adapter(5v = 3000mA)
Keyboard and mouse is connected.(When I removed the keyboard and mouse and switched on the raspberry pi, it stuck at polkit.service)
How can I overcome from this?enter image description here

  • 1
    Do you flashed the image without modifications? It is known that it works if don't use a broken RasPi. – Ingo Jul 19 at 15:03
  • Yes, I flashed the image without any modifications. Then I put a image of Windows IoT, it also gives error(lbue screen errors). It seems there is a issue in Raspberry Pi 3 – Vihanga Ashinsana Jul 20 at 8:35
  • I do not understand. I haven't used Windows IoT yet so I don't know anything about it. What I understand is that you flashed one of these Raspbian Buster images and then put an image of Windows IoT on it. How do you put that image onto the flashed Raspbian SD Card? – Ingo Jul 20 at 8:45
  • First I tried Rasbian. Then I erased SD card and put a Windows IoT image. – Vihanga Ashinsana Jul 20 at 14:17
  • If you booted unmodified Raspbian and it stuck at rc-local.service then your Raspberry Pi is broken. – Ingo Jul 20 at 15:22
1

If you booted unmodified Raspbian and it stuck at rc-local.service then your Raspberry Pi or your SD Card is broken. Try another RasPi or another SD Card. Use another flash program. Verify checksum of the downloaded Raspbian image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.