0

I gained a Raspberry PI board. I want to dive deep in it's programming, but I've faced a disturbing problem: After booting automatically displayed a PDF. I can close it, but I don't want to do regulary, I would like to remove of its boot seqeuence. Where can I do it? I checked the .bashrc file, but it doesn't include reference to this. I found the PDF file, but I'm afraid, if I'w delete it, it would cause issue during boot process. Does someone has any idea? Thanks in advance!

Danesz

  • 1
    What pdf? What is it saying? I don't have a screen or keyboard on my Pis so have never seen this pdf. – joan Jul 20 at 9:47
  • Post a photo of what you are seeing. – CoderMike Jul 20 at 9:58
  • It is connected to display via HDMI. So when the OS boot on, the pdf appears. I can close it, but I'd like avoid it each boot. This modification done by previous user, but I don't want to use it. – Daniel T. Jul 20 at 10:07
  • I guess the sd card was setup by someone else? Could you re-flash the sd card with a fresh image? – CoderMike Jul 20 at 10:12
  • Yes, my ex-colleuge used it, he adjusted this PDF-loading after boot. But we work different company, I cant ask him. Should I format the SD card? – Daniel T. Jul 20 at 10:33
1

Just download a new OS (which will have changed since whatever you are using) and install it. Seeing as you don't know what is on it there is nothing to lose.

See https://www.raspberrypi.org/downloads/raspbian/

1

Personally I would recommend starting with a fresh image. Backup the current image of your sd card to your computer (google how if you need help) you can always go back to it.

With a fresh image you will be sure not to have any other weird artifacts such as you already have with the pdf.

As for the pdf itself, are you sure it's being displayed at boot, or is it displayed at login time? If it's the latter then you should look in the /etc/update-motd.d/ directory to see if any script in there is running it.

0

One place to look for the autoboot sequence is in the /etc/systemd/system folder where you will find files with a .service extension. If the system was setup to display a pdf, you will see it among other services that are enabled to startup when the RPi boots. You will have to determine which service is auto-loading the pdf by executing the following command that will show all enabled services.

systemctl list-unit-files --state=enabled

Once you identify which service is loading the pdf, execute the following command and the pdf should stop displaying when you boot the RPi.

systemctl disable [filename].service

Replace the [filename] with the name of the service that is loading the pdf.

  • A service would be a very awkward way of displaying a file, because services are designed to run independently of user sessions. – Dmitry Grigoryev Jul 21 at 7:58
0

Most likely you have an entry in LXDE autostart file which opens the document. Check ~/.config/lxsession/LXDE-pi/autostart or /etc/xdg/LXDE/autostart.

Another possibility is that session manager is installed, which re-opens some programs on login. Typically the role of a session manager is to restore windows you had open before a reboot, but it's possible that the session manager was either configured to re-open the PDF on every login, or this entry got stuck (e.g. due to a permissions problem) so the document re-opens even if it shouldn't.

Run sudo grep -r "name_of.pdf" * on the root directory and report back the matching files if you need further help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.