0

With my new Pi 4, I am having a ton of difficulty getting the display output correct. I have eventually managed to get the resolution correct with a combination of the boot config and the screen configuration tool, however I still have overscan which I cannot seem to stop. I have tried setting disable_overscan option to one in the boot config, which didn't work, I have also tried setting the overscan_left, overscan_right as well as top and bottom without any luck either.

So far this is my edits/additions to /boot/config.txt

disable_overscan=1
hdmi_group=1
hdmi_mode=20
hdmi_drive=2
sdtv_mode=2

Normally setting the screen res and overscan would work on my other pi 3. So I am a bit confused as to what's going on.

  • If you look down lower in config.txt, by chance is your other Pi 3 using the legacy graphics driver (default) and your Pi 4 using fkms (default for Pi 4)? I don't expect those to behave consistently across hdmi_* settings. – jdonald Jul 22 '19 at 2:45
0

I had this problem on my Raspbian Buster Lite (no desktop) / RPi 4 setup. I am running a very minimal setup but the command line was off the bottom of the screen making it impossible to use. I fixed it by logging in blind and running sudo rpi-update. I understand this issue is known and is being worked on at the time of writing so running the above command should come with the usual warnings about this being untested and your results may vary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.