0

I have two Raspberry Pis. The first is is a Pi 2 Model B. The second is a Pi 3B+. Both are in my shed in the garden.

The first is connected to my LAN via the ethernet port on a Coredy 300 WiFi extender/LAN AP, which in turn is connected to my router via a power line adaptor. It is (and has been) quite happy sending ADS-B info out to the internet for the past year+. I can ssh into it normally.

The second is new and has been loaded, via NOOBS, with Raspbian. It is connected via WiFi and the Coredy 300 to my LAN. My router, an EE smart hub is in the house of course and I wish to SSH into both Pis from my iMac. Unfortunately, when trying to ssh into Raspi2 I keep getting a "192.168.1.180 port 22 connection refused".

I don't know how to resolve this. My router says that Raspi 2 is wired (which it is not) and is coming in on port 4 (along with 5 other devices. Any help forthcoming would be greatly appreciated as I have now reached the (shallow) bottom of my pool of SSH/WiFi knowledge.

3

How very foolish of me. Being a bit used to stretch lite, I didn't delve into the full Raspbian GUI. When I did, sure enough, going to preferences/Raspi configure/interfaces, there it was, by default - ssh disabled. Selected ssh enabled, pressed ok, job done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.