Looking for a 64-bit version of Linux for the Raspberry Pi 4.

I'm aware that support under Ubuntu Mate is in the works, apparently Ubuntu Server works but it limited to using 1 GB of RAM.

Are there any other options that are working now?

  • 1
    when using google to search "64bit version of Linux for the Raspberry Pi 4" - I get exactly what presumably you got (assuming you used a search engine at all) - many promises of future releases, not much else Commented Jul 21, 2019 at 22:27
  • 2
    Yes, I did Google before asking. :-) Commented Jul 21, 2019 at 22:51
  • I'm just saying you didn't miss anything, and there's not much chance that there's a secret 64bit OS out there :p Commented Jul 21, 2019 at 22:55
  • 1
    One of the reasons the Foundation has not developed a 64 bit OS is because no one can come up with a compelling reason.
    – Milliways
    Commented Jul 22, 2019 at 4:08
  • 1
    Don't search "raspberry pi 4". Just leave the 4 off. You are looking for a 64-bit ARM8 OS, (aka. aarch64). There have been a few around for years, although they may not be specialized for the pi, if they say they run on a pi, they will run on a Pi 4.
    – goldilocks
    Commented Jul 22, 2019 at 12:55

12 Answers 12


As of September 2019, the following 64-bit operating systems run on a Raspberry Pi 4:

The above list is by no means exhaustive because there have been many one-off 64-bit experiments ("Hey, it boots") starting shortly after Pi 4's release.

After all, the procedure for tweaking an existing distro into a 64-bit Pi 4 compatible one has not changed. Just like with a Pi 3 or Pi 2 v1.2, copying over the kernel and kernel modules from a working system will usually result in a configuration that boots*.

In terms of quality and support, the situation with Raspberry Pi 4, Buster, kernel 4.19+, and 64-bit is better than it had been with Pi 3B+ and Stretch. This time it is actually possible to access the SoC camera in Fake KMS mode. Gentoo has been listed first for its active userbase and it was the first to provide fixes for accessing 4 GB of memory and V3D acceleration.

Note that for distros without an arm64 userland (e.g. Raspbian + 64-bit kernel), additional steps are necessary to run 64-bit programs. This can be done via static compilation, containers (LXC, systemd-nspawn), or chroot. The last option has proven to be the most straightforward:

sudo apt install -y debootstrap schroot
cat << EOF | sudo tee /etc/schroot/chroot.d/pi64
description=V3D arm64 testing
sudo debootstrap --arch arm64 buster /srv/chroot/pi64
sudo schroot -c pi64 -- apt install -y mesa-utils sudo
schroot -c pi64

Then continue to install more arm64 programs or run them inside the chroot:

(pi64)pi@raspberrypi:~ $ glxgears

* One pitfall specific to Pi 4 is that fake KMS with VC6 requires a very recent build of Mesa, so an initial workaround is to edit config.txt to switch to legacy mode.

  • You are right, and the current best solution is Manjaro. Gentoo comes with GUI which requires extra effort for removing it and Raspian, as you said, also requires extra effort for running on 64 bits. Commented Sep 27, 2019 at 17:29
  • The manjaro link is broken. It should be: manjaro.org/download/arm/raspebery-pi-4/…
    – zbeekman
    Commented Oct 14, 2019 at 22:45
  • sudo debootstrap --arch arm64 /srv/chroot/pi64 fails with """ I: usage: [OPTION]... <suite> <target> [<mirror> [<script>]] E: You must specify a suite and a target. """ Commented Jan 29, 2020 at 14:19
  • This seems to work better: sudo debootstrap --arch arm64 buster /srv/chroot/pi64 Commented Jan 29, 2020 at 14:21

BalenaOS just released its support for RPI4. I have not tried it yet (I will test it in the coming days) but it looks promising.

You can check their blog post regarding the release here.

And the Get Started here


Edit: Ubuntu has published new images for raspberry pi which allow you to use Raspberry Pi 4 4GB with Ubuntu 19.10.1 64-bit out-of-the-box. See the blog post

As of December '19, you can use Ubuntu 19.10 without limiting your ram to 3GB. Assuming you have downloaded 64-bit Ubuntu server image, you can follow these instructions and add eoan-proposed apt sources. Then you do your usual apt update && apt upgrade, and your Ubuntu kernel is upgraded to a version which fixes the USB bug on 64-bit Ubuntu install on Raspberry Pi 4 4GB model.

  • 1
    Are you sure it supports all 4GB of RAM? I remember that I've read it's using just 1GB of RAM. Commented Jan 13, 2020 at 22:39

You can get Raspberry Pi 64bit image on Github. PI64 os Or you can check out the following discussion on StackOverflow Rpi 64bit Os. I hope these links are helpful to you.

  • 1
    pi64 a.k.a. bamarni pi64 is not compatible with the Raspberry Pi 4 at this time. See comments and associated links.
    – jdonald
    Commented Jul 22, 2019 at 16:08

There was an official beta release of the 64-bit version of Raspberry Pi OS as announced in the Raspberry Pi Blog end of May 2020. The 64-bit images of Raspberry Pi OS can be downloaded from here.


I used this image succesfully: https://jamesachambers.com/raspberry-pi-ubuntu-server-18-04-2-installation-guide/ Only had to make some changes in the /boot/firmware/config.txt. I used a 7" touchscreen.

  • 4
    What changes are needed in /boot/firmware/config.txt? This would improve your answer a lot.
    – Ingo
    Commented Sep 12, 2019 at 10:19
  • Changes: lcd_rotate=2, framebuffer_width=960, framebuffer_height=576. Changes needed for my 7" touchscreen.
    – HDK Bouma
    Commented Sep 12, 2019 at 11:24
  • 1
    I have thought that you edit your answer and make it a better answer. Please take the short Tour and visit the Help Center to get an idea how things work here.
    – Ingo
    Commented Sep 12, 2019 at 13:17
  • Given that it could be a bit more elaborate than "this works", I believe his answer is good enough as it is. Those changes are specific to his own screen setup and not directly related to the question so it is a good choice to omit them. Commented Sep 16, 2019 at 7:31
  • Thank you Tuncay. My goal is to point at the jamesachambers image.
    – HDK Bouma
    Commented Sep 17, 2019 at 8:06

There's already a full 64bits Kali linux available with support of all the 4Gb ram memory : https://www.offensive-security.com/kali-linux-arm-images/#1493408272250-e17e9049-9ce8 For memory, kali is a debian with security check pre-installed packages/app, it is based on the debian unstable branch, but from tests I made, you can also "convert" it to the debian testing branch (= the next debian release). If you want to have a try on it, here's the rpi 2 3 & 4 img file of Kali Linux RaspberryPi (2 (v1.2), 3 and 4 64-Bit) : https://images.offensive-security.com/arm-images/kali-linux-2019.3-rpi3-nexmon-64.img.xz another thread related to running a 64 os on the RPI 4 is here, and could interest anyone looking for a 64 bit os (it's on the dietpi forum, for memory dietpi is a very small debian/raspbian os (available to flash as an img or installable through a shell script to reduce and remove a lot of useless packages, allowing you to install ONLY what you really need)) : https://dietpi.com/phpbb/viewtopic.php?f=9&t=6065&start=30


I offer the following procedure on how to install Ubuntu 19.10 on a Pi4

I got most of the following information from the following youtube site  Give it a listen because it is quite accurate in the part it covers.  The only missing piece was how to configure a network on the Pi4 that has virtually no network tools installed. 

This procedure will be self contained with outside references where necessary for clarity or additional reading.

The procedure consists of 7 sections:

  1. download the Pi 4 iso image
  2. install the iso image on your sim card (32Gig) with modifications
  3. after successful boot on the Pi 4 configure your Pi 4 networking - the Pi 4 has no networking tools supplied with the image, i.e., no "ifconfig", "iwlist", etc.  This makes configuring the network a bit more difficult.
  4. updating and upgrading your Pi 4 once connected to the network/internet
  5. installing a desktop manager
  6. installing a second desktop - ubuntu desktop gnome3
  7. logging in with the desktop manager and configuring your wifi network.

Now for the details on how to do this:

  1. Download the Pi 4 iso image from https://ubuntu.com/download/iot/raspberry-pi  Get the 64 bit version.
  2. Install the iso image on your sim card.  I use the tool called balenaEtcher.  Its quite simple to use but you may use what ever you are used to.  After the image has successfully transferred to your sim card those of you with the 4 GB Pi 4 need to do the following:  using the file manager on your ubuntu laptop find "system-boot" and click it.  This will reveal all the files/directories in this filesystem.  Now do the following:  edit the file called usercfg.txt and add the following two lines:  total_mem=3072 and dtparam=audio=on.  These two lines should be left justified in this file.  Do not forget to save this file on the sdc card.  Without these two lines a Pi 4 will boot to login and as you reach for the keyboard the login will scroll off the screen and you are done no matter how many times you boot/try again.  The login/password pair is ubuntu/ubuntu.  Once logged in you will be asked to reset the passwd for ubuntu user.
  3. Networking - these steps are covered below.
  4. Updating and Upgrading your Pi4 - also covered below.
There is no gui at this point in the installation to configure the network.  What follows is what I did from the Pi 4 command line and was successful.

      1. login to the pi
      2. ip addr --> this will show your network interfaces.  my wifi was wlan0 your could be something like ws1pS0.  It does not matter.  Also note your ethernet interface, most likely eth0.
      3. connect ethernet cable to Pi 4 - yes this is how we will connect to the internet.  trying to configure the wifi at this point was too hard.
      4. sudo ip link set dev eth0 down
      5. sudo dhclient eth0
      6. now this step is a test and it must work or you need to fix why you are not connected to the network
          1. sudo apt install net-tools - this will install the net-tools package.  if it can do this then you are successfully connected to the internet and may continue with step 7.  If not you need to get network connectivity because many of the commands that follow require connecting to the Ubuntu site.
      7. sudo apt update
      8. sudo apt upgrade
      9. sudo apt install ubuntu-mate-desktop - this is a one hour install
      10.  when the desktop completes choose xdm (lightdm is another choice but I have not tried it).  This too is a long install.
      11. sudo apt install ubuntu-desktop - this desktop will fix wifi errors that I saw but just remain a bad memory for me.
      12. disconnect the ethernet cable
      13. sudo shutdown -Fr now
      14. you will now be presented with an ubuntu gnome 3 desktop.  login:  ubuntu/your new password
      15. now set up wifi.
        1. at the very top of the screen you will see a couple of icons.  There might be a network icon so click on it.  I there is no network icon click in that region and it will show you a wifi network icon.  click on it and begin to configure your wifi network, i.e., its name and password, dhcp, etc.  The network icon may now have a "?" mark in it so reboot.  This should fix the question mark issue and you will now have a Pi4 running Ubuntu 19.10.
        2. open Firefox and if you can surf then your networking is good.
        3. click on network manager and see if you can list available networks
        4. let the screen saver/power saver kick in then wake the system.  See if you can list available networks in network manager and if you can surf with Firefox.


  1. if you continue to have a "?" mark over the network icon go to settings ->privacy and set connectivity settings to "off"
  • That youtube link was useful. Commented Nov 3, 2019 at 22:55

Are there any other options that are working now?

The image https://ubuntu.com/download/raspberry-pi works for RPi4 1GB & 2GB models but needs a patch for the 4GB model to work at only 3GB memory limit allocation.



What is this Multiarch?

Debian said: Multiarch lets you install library packages from multiple architectures on the same machine. This is useful in various ways, but the most common is installing both 64 and 32-bit software on the same machine and having dependencies correctly resolved automatically. In general, you can have libraries of more than one architecture installed together and applications from one architecture or another installed as alternatives. Note that it does not enable multiple architecture versions of applications to be installed simultaneously.

Multiarch - HOWTO
Multiarch - Implementation


After the release of the new Raspberry Pi 4 model B, Raspberry PI OS (previously called Raspbian) a Beta version of the 64 bit was published. https://www.raspberrypi.org/forums/viewtopic.php?f=117&t=275370

UPDATE: There is a new version of Raspberry OS on 64 bit available here. It is still beta.


On your workstation pc you can now run rpi-imager which has 64-bit OS options:

sudo snap-install rpi-imager

It will provide a graphic environment from which you can select:

e.g. Ubuntu Server 20.04.1 LTS (RPi 3/4) [ 64-bit server OS with long-term support for arm64 architectures]

option to install 64-bit Ubuntu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.