0

I am trying to install mongoDB on my Raspberry Pi 3b+, which has an ARM 4-Core 64 bit processor.

I was trying to install MongoDB on my Pi just as mentioned in their documentation but unfortunately I get the error messages:

N: Skipping acquire of configured file 'multiverse/binary-arm64/Packages' as repository 'https://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 InRelease' doesn't support architecture 'arm64'

and:

E: Unable to locate package mongodb-org

The first message really surprises me as MongoDB mentions that it should be compatible with ARM64 processors: Production Notes

I also made sure that I have 64 bit by issuing the command uname -m which returns aarch64 as a result.

More information about my system:

Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic

I have spent quite a lot of time on that topic now and would be very thankful for an answer that solves it.

  • 2
    bionic/mongodb-org/4.0 has no arm64 image, but bionic/mongodb-org/4.1 does – Jaromanda X Jul 22 at 10:35
0

Have you try below command

sudo apt-get install mongodb

If not, go with this and try. Alternative solution for your problem are

  • Using the cloud is not an option. sudo apt-get install mongodb does not install the newest official mongoldb server. A docker image also does not work. – linus_hologram Jul 22 at 19:02
  • I think no link available for downloading new version of mongodb on offical site of mongodb for arm arch. And I think docker image option is better than. – Nikhil Jain Jul 23 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.