1

I have a raspberry pi 3 B+ and an external hdd like this one

Connecting it directly to the pi makes the pi shutdown and restart

I’ve tried to use an external usb hub with power but it still keeps resetting

How can I test if the problems is with the raspberry?


EDIT

For the requested informations:

HUB + PC => Works
HUB on Power (5v 1A) + PC => Works

Raspberry on Power (5v 2A) => Works (some freezes over ssh but I think because of network)
Raspberry on Power (5v 2A) + HUB and HDD on Power (5v 1A) => RPi keeps reseting
Raspberry and HUB and HDD on the original *HUB Power* (5v 1A) => RPi keeps reseting

Raspberry + HDD on Power (5v 2A) => Kinda works (a lot of freezes over ssh the power led shuts down for long periods, 1s-3s)

I know that placing all devices on the original HUB power supply will not work (because it is rated at 1A) but I've tried using two PSU, one for the hub and other for the pi, but it still keeps resetting

I think the hub is not properly powering the HDD and the pi is trying fill the gap


EDIT 2 Added pictures

This works, kinda:

  1. https://i.imgur.com/HJyjdKA.jpg

These doesn't work:

  1. https://i.imgur.com/1sN3Ita.jpg
  2. https://i.imgur.com/2bwiaxT.jpg

Album: https://imgur.com/a/QC14FtV

  • 1
    Does the Pi work if the external drive is not connected? No - the Pi is bad, Yes - the Pi is okay. – joan Jul 23 '19 at 16:44
  • Then why the external powered hub did not work? Shouldn’t it had worked? – Nicos Karalis Jul 23 '19 at 16:54
  • I have no idea. Perhaps you should add details your question and show exactly what did not work (with photos if possible). – joan Jul 23 '19 at 16:56
  • 1
    @joan The OP should post the Amperage rating of his power supply and whether the pi works correctly without the HDD + hub – gatorback Jul 23 '19 at 17:02
1

Test the combination of PC+hub+HDD. If you can transfer large files to and from the PC,<=HUB=> HDD, then you can isolate the problem to the Pi and its power supply. Ensure the rPI has its own power supply and meets the minimum requirement (most likely problem). Try powering the rPi with your iPhone's or iPad power supply.

If you still have problems, then it is likely that the initial current spike to start the drive is drawing more current than the hub can provide. I this case you would need a hub that could source enough current to spin up (transient current) the drive to a steady state.

| improve this answer | |
  • I've added the scenarios I've tested, can you take a look? – Nicos Karalis Jul 23 '19 at 17:20
  • I do not see an test result for: PC+hub+HDD. Verify that you can copy a large file to and from the PC and HDD. Does the rPi have its own power supply: if yes what is the supply's current (Amperage rating), which powers the rPi? – gatorback Jul 23 '19 at 17:28
  • PC+HUB+HDD does work, like I've said in the first edit. Even PC+HDD works just fine. – Nicos Karalis Jul 23 '19 at 17:32
  • If 'PC+HUB+HDD' works correctly, then the problem is within 'rPi+PS', where PS is power supply. Try powering with supply rated at least 1.5 A. – gatorback Jul 23 '19 at 17:35
  • Like this: i.imgur.com/1sN3Ita.jpg ? The white PS is rated at 2A and it still doesn't work – Nicos Karalis Jul 23 '19 at 17:36
1

Test your system with my "rpiburn" program. It is designed specifically for power supply testing: https://github.com/ronny-nilsson/rpiburn

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.