0

I am trying to install Bind 9 on a PI 4b running Buster. Having done sudo apt-get update, I enter: sudo apt-get install bind9 bind9utils dnsutils.

The error messages that come back indicate that Bind is not yet in the Raspbian Buster repository. I even tried installing it from the desktop installer, and got the same result.

  • 1
    apt policy bind9 on my Pi4 says it's available. Please add the full error message to your question. – Dirk Jul 24 '19 at 20:18
  • Rpi4 Raspbian 10 buster here. (1) $ sudo apt-get update has 2 erros and 3 warnings. (2) $ sudo apt-get install bind9 ... has 6 Err's and 7 E's. I am not surprised because I already found a couple of other similar problems of software/driver not ready for Rpi4. – tlfong01 Jul 25 '19 at 1:08
3

I have tested it with a fresh flashed Raspbian Buster Light on a RPi 4B:

$ sudo apt-get install bind9 bind9utils dnsutils
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  dns-root-data libirs161 python3-ply
Suggested packages:
  bind9-doc ufw rblcheck python-ply-doc
The following NEW packages will be installed:
  bind9 bind9utils dns-root-data dnsutils libirs161 python3-ply
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,675 kB of archives.
After this operation, 4,605 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf libirs161 armhf 1:9.11.5.P4+dfsg-5.1 [235 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf dnsutils armhf 1:9.11.5.P4+dfsg-5.1 [361 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf python3-ply all 3.11-3 [65.1 kB]
Get:4 http://raspbian.raspberrypi.org/raspbian buster/main armhf bind9utils armhf 1:9.11.5.P4+dfsg-5.1 [422 kB]
Get:5 http://raspbian.raspberrypi.org/raspbian buster/main armhf dns-root-data all 2019031302 [5,396 B]
Get:6 http://raspbian.raspberrypi.org/raspbian buster/main armhf bind9 armhf 1:9.11.5.P4+dfsg-5.1 [587 kB]
Fetched 1,675 kB in 1s (1,964 kB/s)
Preconfiguring packages ...
---snip---

So you have to look at your setup, first at /etc/apt/sources.list, or use a fresh flashed image. You may also try to reinitialze the package lists. How to do it you can look at Raspberry Pi sudo apt-get update not working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.