0

I am new to Linux OS's, but I purchased a Raspberry Pi recently, so I can run my usb moonlander 2 scrypt miner because of the low energy consumption (since mining Alt Coins in CA is expensive). I am having issues installing these packages:

sudo apt-get install -y libcurl4-gnutls-dev libjansson-dev

I tried removing the '-y', since other examples do not include this. However, I am still getting the following errors:

E: Unable to locate package libcurl4-gnutls-dev
E: Unable to locate package libjansson-dev

Finally, I tried to install the following package (libcurl4-openssl-dev) and the error says that this has been deprecated.

Thank you for pointing me in the correct direction.

  • 1
    These packages are both available on Raspbian Buster. Did you make sure to sudo apt update first? Also your error message says libcurl-gnutls-dev instead of libcurl4-gnutls-dev. Is that a typo/copypaste issue? – jdonald Jul 25 at 17:23
  • Thank you for responding. 1) Yes, I did the sudo apt update before installing the other libraries. 2) Yes, the I copied and pasted the errors from a different post, since I am not at home. However, the error displays the libcurl4-gnutls-dev package. – Federico Chin Jul 25 at 21:20
  • 1
    After running the update once more, the installation of the packages executed as expected. Something did not get updated properly in the first place. Thank you all. – Federico Chin Jul 27 at 14:27
1

On my Raspberry Pi 4B with a fresh flashed Raspbian Buster Lite I get this:

rpi ~$ sudo apt-get install -y libcurl4-gnutls-dev libjansson-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libcurl3-gnutls libjansson4
Suggested packages:
  libcurl4-doc libgnutls28-dev libidn11-dev libkrb5-dev libldap2-dev librtmp-dev libssh2-1-dev
The following NEW packages will be installed:
  libcurl3-gnutls libcurl4-gnutls-dev libjansson-dev libjansson4
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 726 kB of archives.
After this operation, 1,880 kB of additional disk space will be used.
Get:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf libcurl3-gnutls armhf 7.64.0-4 [291 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libcurl4-gnutls-dev armhf 7.64.0-4 [365 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf libjansson4 armhf 2.12-1 [34.6 kB]
Get:4 http://raspbian.raspberrypi.org/raspbian buster/main armhf libjansson-dev armhf 2.12-1 [35.0 kB]
Fetched 726 kB in 1s (706 kB/s)
--- snip ---

So please check your installation. It seems there are some wrong configurations in particular with the packet manager. First look at /etc/apt/sources.list if it points to the default Raspbian repository. If you can't find the source of your problem you can start again with a fresh flashed image.

You can also try to reinitialize the apt package lists. How to do that you can look at Raspberry Pi sudo apt-get update not working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.