1

I'm trying to install Rocketchat on my Raspberry pi by following these instructions
When trying to install rocketchat-server using Snap I get the following error:

error: cannot perform the following tasks:
- Run configure hook of "rocketchat-server" snap if present (run hook "configure": "((enable)|(disable))" is not a valid, set to enable or disable)

I have searched thoroughly, trying several search terms, but I can't find any results with the same or a similar error.

0

The instruction is for Raspberry Pi 4 or later hardware only.

The Rocket.Chat server has grown in size and hardware requirement; you will need a board with 2GB of RAM or more.

We have tested the procedure with the latest available release of Raspbian; and many in our community have had success installing the server via snap. If you are using an older board or an older version of Raspbian, the error you reported is a possible showstopper.

Please make sure you are following the instructions precisely, and you have:

  1. Raspberry Pi 4 - 2GB or 4GB RAM
  2. The latest available Raspbian Buster Lite for Pi 4.
  3. Installed snapd as per instructions
  • We're looking for long answers that provide some explanation and context. Don't just give a link; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed or you risk to get down votes. Please take the short Tour and visit the Help Center to get an idea how things work here. – Ingo Jul 28 at 10:10
  • I see... I was trying to install it on my Raspberry Pi 3. I'll try again when I get a Raspberry Pi 4, thanks for the answer. – Michael Sep 10 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.