I read MagPi 84 Aug 2019 page 44 Melissa LeBlanc_Williams's article on using Rpi4 circuitPython to control a robot using two boards:

(1) BNO055 9-Degrees-of-Freedom (DOF) Absolute Orientation Module, and

(2) PCA9685 16-Channel 12-bit PWM/Servo Driver Module.

I followed the instructions to install python3, setup tools, adafruit-blinka library. I got stuck at Step 8:

pip3 install adafruit-blinka

The error message was:

cannot find version that satisfies the requirement, ... no matching distro found for adafruit-blinka

My configuration is Rpi4B 2GB Raspbian 10 buster.

Any help or tip appreciated.

Update 2019jul27hkt1629

@milliways' Rpi4B buster works OK. I am not sure if the reason is that my kernel is too old. I need to update my kernel and tried again.

I checked that my raspbian release date was 2019jun20. The latest release is 2019jul10. I guessed beside the kernel, there might be other packages or drivers out of date. I might have also installed other conflicting software when I played with other things earlier. So I guessed the cleanest solution is to start everything from scratch: download the latest raspbian, and first thing first is to install Adafruit circuit python blinka.

So I installed Raspbian (buster 2019jul10) again. The welcome screen says the release page is not ready, until some 20 days later. I guess this might cause trouble. So I exit GUI desktop straight away and start installing circuit python blinka in terminal mode.

This time everything went smoothly. My conclusion that the root cause of my installation problem is that my Raspbian dated 2019jun20 is out of date. I might also installed other packages earlier and they crash with circuit python's blinka library.

Anyway, problem solved.

Update 2019aug08hkt1121

I have also clarified my mind on why using "sudo pip3 install" first, and just "pip3 install" (no sudo) later. See this thread for details: No module named 'adafruit_circuitpython_servokit'

  • 1
    We do not mark the headline [Solved]. This is shown by accepting an answer.
    – Ingo
    Commented Jul 27, 2019 at 15:47
  • Well, some forums advise to mark the question solved, for the following reasons: (1) Future readers won't waste time reading questions without answer, (2) Future readers who would like to learn something from the topic. Some forums recommends/encourage to mark the question solved. Some forums auto mark question solved when accepted. Some forums even has "best" answer option, or place answer with most upvotes at top. "How do mark my own Topic as SOLVED?" Thread starterKreelor Start date Apr 21, 2010: forums.tomshardware.com/threads/….
    – tlfong01
    Commented Jul 28, 2019 at 1:28
  • Actually I did both. I FIRST accepted the answer, with an extra up vote, BEFORE I marked the question solved. I always wish I can rate the answer with points, say 5 out of 10. I also wish to mark some answers as "out dated", or "only for jessie, not stretch" etc (That is why I "marked" my question "for Rpi4 only"). When I was a Rpi newbie a couple of years ago, I actually wasted a lot of time reading and trying out outdated answers.
    – tlfong01
    Commented Jul 28, 2019 at 1:37
  • You told me how other sites handle this but that's not Raspberry Pi. As far as I know it was said anywhere that we should not mark the headline [Solved] so I have searched for a policy in the Help Center without success. Let's discuss it on meta.
    – Ingo
    Commented Jul 28, 2019 at 9:41
  • @Ingo, OK, let us discuss on meta later.
    – tlfong01
    Commented Jul 28, 2019 at 9:46

1 Answer 1


Works here:-

 sudo pip3 install adafruit-blinka
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting adafruit-blinka
  Downloading https://www.piwheels.org/simple/adafruit-blinka/Adafruit_Blinka-2.2.0-py3-none-any.whl (79kB)
    100% |################################| 81kB 123kB/s 


- Original Installation
Raspberry Pi reference 2019-06-20
- Current OS
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 10 (buster)
Release:    10
Codename:   buster
- Kernel
- Model
Raspberry Pi 4 Model B Rev 1.1
  • Hi @Milliways, Please confirm if you are using Rpi4B Raspbian 10 buster. Thanks.
    – tlfong01
    Commented Jul 27, 2019 at 8:04
  • I would not have answered otherwise!
    – Milliways
    Commented Jul 27, 2019 at 8:06
  • My apologies. Let me check where I did wrong.
    – tlfong01
    Commented Jul 27, 2019 at 8:09
  • Your kernel is 4.19.58. Mine is 4.19.50. So I guess I need to update/upgrade something. Many thanks for your help and tip.
    – tlfong01
    Commented Jul 27, 2019 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.