2

Is it possible to run Raspbian Stretch on the Pi 4?

The problem is that the newest released (Raspbian Buster) has some weird bug in which JavaFX applications cannot be started with the error : "*failed to add service - already in use?"

  • I tried to boot Rpi4B with a microSD card with stretch. But Rpi green LED blinks for one or two seconds and then hangs. In other words, Rpi4B hates stretch! :( – tlfong01 Jul 27 '19 at 7:25
  • can you post your config.txt contents – Jaromanda X Jul 27 '19 at 9:18
  • 1
    I've had the same message with a different program. Fix on the Pi was to switch to Full KMS. In my case it's fixed with Buster. – kuzeyron Jul 27 '19 at 10:27
  • 1
    @kuzeyron thanks, your Full KMS suggestion solve partially my issue (stackoverflow.com/questions/57328781/…). I've still got an error: "Could not initialize class com.sun.webkit.WebPage" inside a page where I have to display some web content (using WebPage tool of course). I'm using Liberica jdk11 with javaFx bundled. – mauretto Aug 6 '19 at 7:32
0

I know of no reason why stretch couldn't work.

Nobody seems to have bothered to get it to work so you will have to do the heavy lifting yourself.

I would start by trying to find out why the Foundation chose to use Buster as the base for the Pi4. If there is a show-stopper re stretch they should know.

  • I expected a more real life practical experience -_- this is because buster must run on pi 3b as well. It runs but almost an unusable experience. Raspbian buster has this stupid bug which is really a deal breaker for the pi4 – Debayan Sutradhar Jul 27 '19 at 8:41
  • 1
    I have a Pi4. I don't have any deal breakers. If enough people think your issue is important then it may be fixed. – joan Jul 27 '19 at 10:10
  • because I am working on JavaFX project for raspberry pi and it doesn’t work on the pi 4 raspbian buster. – Debayan Sutradhar Jul 27 '19 at 10:11
  • I read the question. Is there a JavaFX site? If so that might be a way to find people who also want to fix this problem. – joan Jul 27 '19 at 10:54
  • @Joan I'd expect the show stopper is the new FKMS stuff and the kernel7i which aren't in Stretch. The RPF folks chose Buster as that was within two weeks of general availability when the RPi4B launched and it was probably easier to add the new stuff to the new version of Debian/Raspbian. – Dougie Jul 27 '19 at 13:50
0

Stretch cannot run on the Pi 4; the foundation timed the release of the Pi 4 with the release of Buster to save money.

But... I have just released a script that will run a Raspbian Stretch virtual machine, inside the Raspbian Buster operating system. Not sure if it's helpful in your case, but definitely something to try.

Let me know how it goes. vdesktop script

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.