I've tried to install Hamachi using the instructions on the official Raspberry site as well as similar instructions on Lifehacker, but I haven't been unable to get it to work.

The problem seems to be the armhf/armel infrastructure - if I try to use the armhf version I get an "Illegal instruction" error when the service tries to start. If I try to use the armel version I get "package architecture (armel) does not match system (armhf)".

There are additional command lines in some of the instruction pages, for example

sudo wget https://secure.logmein.com/labs/logmein-hamachi_2.1.0.119-1_armel.deb
sudo apt-get update
sudo apt-get install --fix-missing lsb lsb-core
sudo dpkg --force-architecture --force-depends -i logmein-hamachi_2.1.0.119-1_armel.deb

A lot of comments say that this fixed it for them but I get a "Segmentation fault".

  • What distro do you use? – patchie Oct 18 '13 at 8:32
  • I'm using raspbian. I've updated the tags on the question to show this. – ghosttie Oct 18 '13 at 15:13

I use hamachi for a large project on multiple Pis, but I have had much more luck installing from the .tgz download. Try:

sudo wget https://secure.logmein.com/labs/logmein-hamachi-2.1.0.119-armel.tgz && tar xvf logmein-hamachi-2.1.0.119-armel.tgz

Then run the install bash script.

  • 1
    I still get the "Segmentation fault" error when I run the install bash script: Copying files into /opt/logmein-hamachi .. Creating LogMeIn Hamachi symlink .. Creating TunTap .. mknod: `/dev/net/tun': File exists Installing LogMeIn Hamachi service .. update-rc.d: using dependency based boot sequencing Starting LogMeIn Hamachi service .. Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachiSegmentation fault failed! LogMeIn Hamachi is installed. See README for what to do next. – ghosttie Oct 19 '13 at 19:35
  • 1
    I tried it myself, and had the same problem. It looks like it's an issue with the current version. I can confirm this version works: wget https://www.dropbox.com/s/b3qmefk60n7ng7v/logmein-hamachi-2.1.0.101-armel.tgz – joe Oct 20 '13 at 5:08

The latest version of Hamachi for linux works without the LSB package

Note: The Linux client can now be installed without LSB package.

Raspberry Pi 3b uses the ARMv8 architecture, so select the "ARM HF version" on the Logmein page. Use wget to download the compressed file set, then install by running the install script.

cd ~
wget https://www.vpn.net/installers/logmein-hamachi-2.1.0.165-armhf.tgz
tar -zxvf logmein-hamachi-2.1.0.165-armhf.tgz
cd logmein-hamachi-2.1.0.165-armhf
sudo ./install.sh

You should see output like this:

pi@raspberrypi:~/hamachi/logmein-hamachi-2.1.0.165-armhf $ sudo ./install.sh
Copying files into /opt/logmein-hamachi ..
Creating LogMeIn Hamachi symlink ..
Creating TunTap ..
mknod: ‘/dev/net/tun’: File exists
Installing LogMeIn Hamachi service ..
Starting LogMeIn Hamachi service ..
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachi
starting - success
LogMeIn Hamachi is installed. See README for what to do next.

Now set up Hamachi

$ sudo hamachi login
Logging in .......... ok
$ sudo hamachi attach my-logmein-username@email.com
Sending attach request to my-logmein-username@email.com without networks .. ok
sudo hamachi set-nick name-of-my-raspberry-pi
Setting nickname .. ok

At this point go back to your logmein.com web account, which should now show that a raspberrypi device named "name-of-my-raspberry-pi" is attempting to access it. Grant it permission. Now you should be connected.

The install script for Hamachi version 2.1.0.165 makes changes to the linux startup config causing Hamachi to start each time linux boots. This way you can still reach your Pi after a power cycle.

You're not using the correct version of Hamachi for Raspbian. Raspbian should be using HardFloat now and the links are:

https://secure.logmein.com/labs/logmein-hamachi_2.1.0.119-1_armhf.deb https://secure.logmein.com/labs/logmein-hamachi-2.1.0.119-armhf.tgz

As joe stated, I've had better luck with using the tgz and manually installing.

  • I've tried both the hf and el verisons and I get errors with both. – ghosttie Nov 10 '13 at 0:12

Ok guys, latest working version is 2.1.0.8.6, newer versions will get you segmentation fault errors.

I uploaded it for you, it is a debfile

http://ul.to/ppisqm61

Instead of install.sh I used the following, install.sh might also work but that's the way I did it:

sudo dpkg -i --force-depends --force-architecture logmein-hamachi_2.1.0.86-1_armel.deb

the new Version "logmein-hamachi-2.1.0.130-armel.tgz" works without probs just install lsb-cor (lsb is not required) dont know if the armhf also works. so: maybe replace link with newesvers. of logmein armel version checkout (logmein)

apt-get install lsb-core
sudo wget https://secure.logmein.com/labs/logmein-hamachi-2.1.0.130-armel.tgz 
sudo tar xvf logmein-hamachi-2.1.0.130-armel.tgz
cd /logmein-hamachi-2.1.0.130-armel
sudo ./install.sh

works on weezy / Xbian without probs.

I faced similar issues while using logmein Hamachi; as a result I switched to an alternative solution: RHUB remote support appliance. It simply works flawlessly from behind my firewall without any hassles.

  • 1
    Perhaps you could add a link to the product page, download page and a small manual how to install it. – M. Mimpen Mar 20 '14 at 11:30
  • Interesting hint, but I can't find a client for Raspberry PI?! – mgutt Jul 25 '14 at 20:15

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.