For some reason RaspiStill has lost some of its functionality. When I tried to use the -tl argument it doesn't produce any photos and seems to hang up.

The full command I am running is:

raspistill -rot 180 -q 80  -w 1920 -h 1080 -t 300000 -tl 999999   -o /media/64GB/www/timelapse/timelapse_%d.jpg

I am able to take photos without the -tl I have tried adjusting the amount tl is, I have also tried adding the -n flag.

For example:

raspistill -rot 180 -q 82 -w 1920 -h 1080 -n -t 120000 -tl 999999 -o /media/64GB/www/timelapse/photo_%d.jpg

Any suggestions?

1 Answer 1


The -tl timelapse option says to take a picture every <t> milliseconds. By using 999999 you're specifying to take a picture every ~999 seconds. Try using a smaller number such as 1000 to take a picture every second.

I do know that there are issues that cause the camera to hang such as specifying a very-long exposure, see https://github.com/raspberrypi/userland/issues/33 for more details on that issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.