2
  1. I finally got into the Pi world with a model 4B. I've updated it to Raspian/Buster and have the network working (wireless and wired - but just using wireless right now).

  2. I'm running it using VNC-Viewer-6.19.325-Linux-x64 from my Linux workstation but have the HDMI output connected to my TV which can only do up to 1080i. tvservice -m CEA shows it supports 6 modes, 3 progressive up to 720x480 @ 60Hz, 16:9; and 3 interlaced with 1920x1080 @60Hz, 16:9 being marked (prefer). The supported CEA modes are 1,2,3,5,6 & 7.

  3. I know it can do mode 5 (the one marked prefer) because I have had various cable boxes and DVD/Blu-ray players connected to it and they all worked once I got them to display 1080i (surprising how many devices don't want to start in a broadcast-standard mode - I wrote a blog post about it).

Q: Anyway, despite tvservice showing that it can work with 1080i, I've not been able to get it beyond 480p.

I've edited /boot/config.txt to include:

hdmi_group=1
hdmi_mode=5
hdmi_drive=2
config_hdmi_boost=4 (also tried without it)
hdmi_force_hotplug=1
hdmi_edid_file=1

with a /boot/edid.dat file for that last option created by running tvservice -d edid.dat.

The best I can get my Pi to use is 720x480p using Preferences | Screen Configuration then following the right-click menu. There are no higher resolution options shown, just 720x480 and 640x480, each at 60Hz or 59.94Hz (However, even those are not usable on my TV because of the tremendous overscan - I loose a large chunk of the desktop. I can only see it all through VNC. Uncommenting "disable_overscan=1" seems to make it worse).

Q: Any idea how I can get the Pi to connect to my TV in 1080i?

added details: While working with the TV screen on, I ran

    tvservice -e "CEA 5 HDMI"

and the TV eventually synced to the signal. When switching from 640x480, it took over 3 minutes but going from 720x480 was only a few seconds. Both left me with the original desktop in the top left corner. So the hardware bits can apparently talk to each other. However even when the screen is in 1920x1080, the desktop is still the same size as it booted with.

By unplugging the HDMI cable, I was able to run the Pi headless using VNC. From there I was able to set it up to 1920x1080 at 59.99Hz (?). Re-plugging the cable and running the tvservice command (above), I could see the desktop on the TV. However the picture is still overscanned.

more updates: By using a edid file - which clearly shows that the TV supports 1080i and not 1080p, I have got the Pi to boot into a 1920x1080 display with the TV attached. Unfortunately it insists on using 1080p. I confirmed this by using VNC and tvservice -s from a command line.

The lines in /boot/config.txt are:

hdmi_group=1
hdmi_mode=5
hdmi_drive=2
hdmi_force_hotplug=1
hdmi_force_mode=1
hdmi_ignore_edid=0xa5000080
hdmi_edid_file=1
hdmi_edid_filename=/boot/edid.dat

When I run tvservice -e "CEA 5 HDMI" it puts it into the correct (interlaced) mode and I have a (horribly overscanned) 1080 line desktop.

Again, the edid.dat file (as parsed by edid-decode) shows the modes as:

Video data block
VIC   5 1920x1080i@60Hz 16:9  HorFreq: 33750 Hz Clock: 74.250 MHz
VIC   3 720x480@60Hz 16:9  HorFreq: 31469 Hz Clock: 27.000 MHz
VIC   2 720x480@60Hz 4:3  HorFreq: 31469 Hz Clock: 27.000 MHz
VIC   7 1440x480i@60Hz 16:9  HorFreq: 15734 Hz Clock: 27.000 MHz
VIC   6 1440x480i@60Hz 4:3  HorFreq: 15734 Hz Clock: 27.000 MHz
VIC   1 640x480@60Hz 4:3  HorFreq: 31469 Hz Clock: 25.175 MHz

but the Pi seems to be ignoring them and only using progressive scan modes unless forced from the command line. I could probably live with this except the tvservice command doesn't let me adjust the overscan settings so I don't have a usable desktop on the TV.

When I use Preferences | Screen Configuration, I now see a full range of what appear to be DMT modes, including 3 1920x1080 at 60Hz, 59.94Hz and 50Hz. When I switch to any of them using the Screen Configuration tool, tvservice -s (through VNC) confirms they are all Progressive Scan.

Q: How can I get my Pi 4 to accept the edid data and boot into 1080i?

  • have you tried using hdmi_edid_file=1 rather than hdmi_edit_file=1? since the former does something and the latter does not? Also, have you considered hdmi_force_mode=1? – Jaromanda X Jul 28 '19 at 23:39
  • Sorry, typo on my part. It does say edid, not edit. – Gary Dale Jul 29 '19 at 3:20
  • Tried hdmi_force_mode=1 and it still booted into a 480 mode. – Gary Dale Jul 29 '19 at 16:03
  • You wrote: "...with a model 4B. I've updated it to Raspian/Buster...". You cannot update it. You have to start with Buster. There is no previous Version that you can update. – Ingo Jul 30 '19 at 16:19
  • Ingo yes and no. It starts with Buster but as a testing distribution. I updated it to Buster as a stable distribution. Frankly, the original software name is not an issue. – Gary Dale Jul 30 '19 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.