1

Just got a Raspberry Pi4B, I have tried all night to get this to work and have had no luck. Both the red and green LED indicators are both on, not blinking. I have followed all troubleshooting advice I have seen (new NOOBS, etched Raspbian, recovery.bin) and cannot get it to output anything to HDMI or even get the green LED to begin blinking. Plugging in has never caused the green lights to blink, regardless of whether or not anything else is inserted. Wired devices such as keyboards and mice don't power up when plugged in (no leds in keyboard for instance). Recovery.bin did not cause the green LED to flicker. Did my Pi brick in transport or something?

  • Hi @Connor, I installed Rpi4B 2GB Raspbian 10 buster full desktop version release 2019jul10 without any problem. I use Win10 Win32DiskImager v1.0 to install OS image to 16GB micro sd card. If you like, you can try my way and see any luck. If still no luck, I can repeat your procedure step by step, compare and contrast things to verify that your Rpi4B is indeed bricked! :) – tlfong01 Aug 1 at 5:41
  • @tlfong01 I essentially tried the same thing, using etcher instead and on a 32GB micro SD. I just get no activity from the green LED at all, it is always on, never blinking/flashing. This doesn't seem to be a common problem as far as I can tell. I will try using Win32DiskImager to install the image and give you an exact step by step – Connor Aug 1 at 5:46
  • Hi @Connor, I agree yours is not a common program. I suggest to do the following to make very sure: (1) Use 16GB, not 32GB sd card, (Yes, I am superstitious!) (2) Use SD Formatter v4.0/5.0 to fully overwrite format (not quick format), (3) Then Win10 to fully format (again not quick format) in exFAT (not FAT, not NTFS), making sure you have about 16BG, not 48MB or something. (4) Only then I use Win DiskManager v1.0, with SHA256 hash, ... Lunch time, see you later, ... – tlfong01 Aug 1 at 6:05
  • Hi @Connor, So I created another 16GB SD card and boot Rpi4 without any problem. I am going to create another 32GB card later. I have captured some screens for your comparison. penzu.com/p/ad8cf446. – tlfong01 Aug 1 at 7:50
  • Hi @Connor. (1) If I insert an old stretch card, green led blinks twice or three times and then off for ever. (2) If I I insert NO card, the green led repeats the following 2 steps continuously: (a) blink 4 times, (b) off one or two seconds. I never heard about your case, so I agree your problem is not common. – tlfong01 Aug 1 at 8:05
1

This is not a problem covered by The Boot Problems Sticky

I suggest you try removing the SD Card - where the green LED should blink 4 times alternating with long solid green.

If not you probably have a hardware problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.