0

I am a Linux user but a bit of a noob with respect to the Pi. I have a Pi that was running Raspbian Stretch with GassistPi as a tinkering tool and a sort of attraction, to tinkering, for my kids. However, I broke the SD card in an accident, and had to get a new one.

Now, when I reinstall Stretch from the copy of NOOBS I had bought, it automatically upgrades itself to Buster. But GassistPi is not yet able to run on Buster. In some of the issue comments in this and linked issues, there are references to running Raspbian Stretch. Is there a way I can install Stretch without the auto-upgrade to Buster? Is this a problem because of the scripts in NOOBS?

5

Raspbian will NEVER upgrade to a different OS.

NOOBS, on the other hand always installs the latest version (or the copy included with NOOBS) - I might add that very few experienced users of this site use NOOBS .

If you don't have a backup, you can install any released version of Raspbian.

Pick one from https://downloads.raspberrypi.org/raspbian/images/

AFAIK 2019-04-09 23:46 is the latest Stretch release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.