0

I am working on a Raspberry Pi 3 B+ board with Raspbian GNU/Linux 9.9 (stretch) I am trying to install libssl1.0.0 packages using the following commands:

sudo apt-get update 
sudo apt-get upgrade
sudo apt-get install libssl1.0.0

But I'm getting the following error:

root@raspberrypi:/home/pi# sudo apt-get install libssl1.0.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libssl1.0.0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package 'libssl1.0.0' has no installation candidate

Later on I've even installed:

sudo apt-get install libssl-dev

But it's still not able to resolve the dependencies. How can I install libssl1.0.0?

  • a quick search shows zipgateway is only "available" for raspbian jessie – Jaromanda X Aug 2 '19 at 10:51
3

I fixed with the steps below:

  1. Download libssl1.0.0 from https://packages.debian.org/jessie/armhf/libssl1.0.0/download (I made this with WinScp tools, with a ssh connection with a Windows10 host).
  2. In the folder containing this package run: dpkg -i libssl1.0.0_1.0.1t-1+deb8u12_armhf.deb
  3. Finally run: dpkg -i zipgateway-2.81.03-Linux-armhf.deb

For me it works

1

Using deb files written for Jessie can be problematic with mismatched dependencies, but if libssl-1.0.0 is the only missing one it has complained about so far, there's hope.

Here is a recipe to work around this not-too-uncommon error at your own risk:

ar xv zipgateway-2.81.03-Linux-armhf.deb

mkdir -p tmp
cd tmp
tar xvf ../control.tar.*
sed -i 's/libssl1.0.0/libssl1.1/' control
tar cJf ../control.tar.xz *
cd ..

ar cr zipgateway-2.81.03-Linux-armhf-patched.deb \
  debian-binary control.tar.xz data.tar.*
sudo apt install ./zipgateway-2.81.03-Linux-armhf-patched.deb

That may successfully install the package or may identify other missing dependencies to work through. Once you get around to running the program it's unlikely that it will depend on any OpenSSL 1.0.0-specific bugs at runtime, but there may be other incompatibilities taking a binary from Jessie to Stretch.

All the more reason you should put as much information as possible in your question description with regards to this particular zipgateway Jessie package.

0

Your installation says

Package libssl1.0.0 is not available ...

So just look what's available with

rpi ~$ apt list libssl*
Listing... Done
libssl-dev/oldstable 1.1.0k-1~deb9u1 armhf
libssl-doc/oldstable 1.1.0k-1~deb9u1 all
libssl-ocaml/oldstable 0.5.2-2 armhf
libssl-ocaml-dev/oldstable 0.5.2-2 armhf
libssl1.0-dev/oldstable 1.0.2s-1~deb9u1 armhf
libssl1.0.2/oldstable,now 1.0.2s-1~deb9u1 armhf
libssl1.1/oldstable,now 1.1.0k-1~deb9u1 armhf [installed]

Try to use libssl1.0.2 instead of libssl1.0.0.

  • Hello, I have tried it to.. still getting error while Im running following command sudo dpkg -i zipgateway-2.81.03-Linux-armhf.deb ERROR : dpkg: dependency problems prevent configuration of zipgateway: zipgateway depends on libssl1.0.0; however: Package libssl1.0.0 is not installed. dpkg: error processing package zipgateway (--install): dependency problems - leaving unconfigured – shiv patil Aug 2 '19 at 10:01
  • zipgateway doesn't seem to be a package available on the standard raspbian repos - where did you get that from? – Jaromanda X Aug 2 '19 at 10:47
  • @shivpatil Please read the comment from @JaromandaX. Please edit your question and update it with the important information you have given in your comment. – Ingo Aug 2 '19 at 11:05
  • actually zipgatewayis out application script which requires above mentioned packages as a dependencies. – shiv patil Aug 2 '19 at 11:07
  • @shivpatil Please add this information to the question as I suggested! It is an important information to understand your problem. You can edit the question. – Ingo Aug 2 '19 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.