-2

I want to create a Cloud9 server using a raspberry pi. I download the repository and it ran just fine in the port 8181 as it shows below. I could even access the panel from the Raspberry using ChromiumCloud9 server running

But when I tried to connect to it from another computer in the same network, it instantly showed me this screen with the error "connection refused", so I assumed it was something to do with the firewall.: Error

I followed some tutorials to allow traffic through port 8181 but nothing worked. Later, I tried using ufw, and configured it like this: UFW configuration

And running the command iptables -L I got: IPTables -L

And I still got the same error when trying to access. Does anyone knows how I can properly allow traffic through the port 8181 or completely disable firewall from my raspberry pi? Thanks

  • 5
    Please don't post images of text. – RalfFriedl Aug 1 at 16:38
  • 1
    Welcome to Raspberry Pi :-) But your question has nothing to do with Raspberry Pi. Please take the short Tour and visit the Help Center to get an idea how things work here. – Ingo Aug 1 at 16:40
0

The problem is not the firewall, your server is bound to the loopback address, 127.0.0.1.

If you want to connect from other hosts, you must change the address to 0.0.0.0.

  • And where is the problem with Raspberry Pi? – Ingo Aug 1 at 16:40
  • I tried that, got the same connection refused error. – Gustavo Cesário Aug 2 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.