2

I'm on a Raspberry Pi model B+. I'm running Raspbian-Lite 9 Jesse. My super lightweight GUI is xorg + fluxbox.

The rdesktop command works great - EXCEPT...

All of these commands give me the same color depth (24). I can't reduce the color depth to 8. I actually can't get any color depth except for 24.

rdesktop -u user@dnsdomain.com -p password -f -a 8  win10propc
rdesktop -u user@dnsdomain.com -p password -f -a 16 win10propc
rdesktop -u user@dnsdomain.com -p password -f -a 24 win10propc
rdesktop -u user@dnsdomain.com -p password -f -a 32 win10propc

Any ideas why rdesktop is just simply ignoring my color depth argument?

3

-a

Sets the colour depth for the connection (8, 15, 16 or 24). More than 8 bpp are only supported when connecting to Windows XP (up to 16 bpp) or newer. Note that the colour depth may also be limited by the server configuration. The default value is the depth of the root window.

It seems that the server you're using is not offering any other depths besides 24 bpp.

3
  • Awesome. I'll check the server and update here. – Rhyknowscerious Aug 6 '19 at 0:50
  • Anybody know how to find this setting on Win10 Pro? – Rhyknowscerious Aug 6 '19 at 1:28
  • On Win 10 Pro. I changed the Group Policy setting “Computer Configuration” > “Administrative Templates” > “Windows Components” > “Remote Desktop Services” > “Remote Desktop Session Host“ > "Remote Session Environment" > "Limit maximum color depth" > Enabled, 16 bit color depth. But I'm still not connecting at that color depth. – Rhyknowscerious Aug 17 '19 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.