1

I have 2 x Raspberry Pi 3s (mine is a 3B, his 3B+). I cloned my SD card for a friend, and the new card works in my Pi. His Pi will only boot to the rainbow screen.

Solid red light on the back. The only difference is I used the Power Supply that came with my kit, and he used a third party one.

Any clues?

Also, when I cloned my card, and reinserted it, it keeps seeing it as two drives. In my This PC, it shows "boot (E:)" with 36.6MB free of 56.8 MB. And it shows USB Drive (G:) with nothing below it. And every time I insert the card into my computer, it tells me I have to format the G: drive to use it. Which I've done. Multiple times. I've cleaned the extra partition and them reformatted... nothing.

I'm super confused here, and I'm a relative noob... so please help a girl out?

  • I have also been super confused for years, since Rpi 1 days, of why my WinPC sees the micro SD card as two drives (I was too afraid to ask, because I am a man!). I was told that WinPC misunderstands the weird partition thing and so shows two drives. Anyway, I usually try one drive F:, if not working, then try another, G:. No problems so far. And for your friend's no boot problem, one of the many reasons is that his power supply (the wall wart) is not strong enough (must be around 5V 2.5A to escape the rainbow and yellow lightning. :)) – tlfong01 Aug 8 at 13:59
  • 1
    Hey man... never be afraid to ask. So, this might sound stupid, but what do you mean "try another drive?" Just literally change the letter? Because since I've tried this multiple times, the drive letters have changed on their own... but the problem persists. We're also trying now on another machine (still Windows 10) and having the same problem. "You must format drive G: to use it." – Becca Sullins Aug 8 at 14:07
  • 1
    Yeah, I've actually tried formatting both, and cleaning one of the partitions off. Still does it... it's so weird. – Becca Sullins Aug 8 at 15:41
  • 1
    So, I found something on another forum that states that I may just need to update my boot software for the 3B+ using a terminal server session. My 3B isn't connected to the internet... is there a way to check and upload the boot file just from the SD card? – Becca Sullins Aug 8 at 15:59
  • 1
    If you constantly erased the second partition, you've wrecked the install. Your computer does not understand the card. Do not pay any attention to what it tells you about what is on the card. Just burn the SD card image using official directions. You can then add stuff to the first partition if you want to set up SSH, etc., but do not do anything else. All your computer can do is wreck what's on the card. – goldilocks Aug 8 at 16:51
2

Your SDCard probably doesn't have the firmware/bootcode for a 3B+, or it's a NOOBS SDCard. If it's NOOBS forget it, write a new card with plain Raspbian Buster 2019-07-10.

If it's not NOOBS then stick the SDCard back in your RPi3B

Run sudo apt update, sudo apt -y dist-upgrade then sudo poweroff Try that back in the 3B+.

If it doesn't work put it back in the 3B and get the experimental kernel and bootcode with sudo rpi-update then sudo poweroff.

Remember if it's got NOOBS forget it, it's a waste of time and waste of SDCard space trying to get it upgraded for the 3B+.

  • 1
    Ah... ok. So that makes sense. But then the question becomes how do I find out what's on there. Another person loaded that part for me and I'm not sure what he used. – Becca Sullins Aug 8 at 17:42
  • 1
    So... I think I'm comfortable with the idea of just sort of reloading from scratch. But the problem above in my first post (two drives, one of them will never open on Windows) is preventing me from seeing the files on the actual SD card to copy them. So if I were to start from scratch, I don't want to lose all my game files. – Becca Sullins Aug 8 at 18:26
  • 1
    Boot the card in your old RPi and run sudo fdisk -l. If there are more than two partitions that card has NOOBS on it. – Dougie Aug 8 at 19:29
  • 1
    PCs have 2 partitions (as a general minimum, often they have more). When viewing drive partitions on a computer they will appear as X number of drives even if it's one physically. Raspian uses the ext4 filesystem on the main partition. Windows cant read ext filesystems, it will always say that partition is unreadable. You should NEVER run windows repair or format on that partition to try and access it on as that will erase/damage the partition. If you want to access the files on that partition you'll have to access them on the pi or from a another linux machine that understands ext filesystems – rohtua Aug 8 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.