I wanted to set up logitech media server on my raspberry pi as a server for my music collection as well as for my favorite web radio stations with the option to synchronize several Squeezeboxes in my home.

I run a freshly installed Raspbian Buster which is 32bit, although the Raspberry is a 64bit chip.


Download Raspbian Buster from here. Extract the ZIP to get an IMG. Install the IMG to a SD card with Win32 Disk Imager on Windows - if you use Windows. After the installation is complete, put a file on the boot partition that is named just ssh to activate SSH login. Log into the Raspi using Putty with username pi and password raspberry. Change your password with passwd pi.

Do sudo apt update && sudo apt upgrade.

Download current stable or nightly version arm.deb with wget. (I tried with last stable version 7.9.1 and was not able to reach the webGUI, that's why I recommend 7.9.2 nightly).

UPDATE: In general, all versions can be found here. For RaspberriPi the arm architecture is necessary. This is the file you want to download with wget.

Install it with dpkg -i arm.de. It will fail with missing dependencies.

Install missing dependencies and complete installation with apt --fix-broken install.

During that process the following packages will be installed:

libio-socket-ssl-perl libnet-libidn-perl libnet-ssleay-perl perl-openssl-defaults

Connect to the web-gui of LMS with a browser: IP:9000.


If you don't get a connection with the browser check if the Raspberry is listing to ports 9000, 9090 and 3483 with netstat -t -l. Output should be like this:

Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0  *               LISTEN
tcp        0      0  *               LISTEN
tcp        0      0  *               LISTEN
tcp        0      0   *               LISTEN
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN
  • 1
    The link arm.deb is broken: The requested URL /nightly/7.9/sc/3765a9f7d34fe653b5029392a972ec064e994acc/logitechmediaserver_7.9.2~1564788734_arm.deb was not found on this server.
    – Ingo
    Feb 17 '20 at 10:22
  • Thank you. But the URL arm.db is broken. Can you fix it ? Maybe we can use 8.1 version from now? Regard. Pierre
    – pierre
    Dec 11 '20 at 14:34
  • I removed the actual link from my answer. Please see the remaining link and find the most recent version folder (currently 8.1). It will be easy to pick the correct file from my answer's description. @pierre Also, please consider upvoting if an answer helped you.
    – bomben
    Dec 11 '20 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.