0

So I'm running Raspbian (I installed with NOOBS initially if that makes a difference) on a Raspberry pi model 3B+ and I can't log in. before anyone says it, I know this question has been posted before, but everyone else seems to be able to SSH in or somehow log in via terminal. I cannot, and I don't know how to access any of the files they say they changed to fix it because, again, I can't log in at all.

Recently I've been trying to make an IoT weather station and have had to boot several times. The most recent time I had to enable i2c so I followed the steps here http://ozzmaker.com/i2c/ up through the reboot step.

When it rebooted, it went to a login screen but every time I entered my info correctly, it would go black, say "cannot show desktop" and return to the login screen. If I enter bad information it tells me it was a bad login as one would expect.

I tried ctrl+alt+F1 and it shows me a screen that just says "Error in service mode" and when I did ctrl+alt+F2 I get a terminal login (Raspbian GNU/Linux 10 raspberrypi tty2) but the same issue. Even on this terminal login, if I enter bad information it says it was wrong and prompts again. When I enter the correct information, everything erases and it prompts me again like I had just hit ctrl+alt+F2.

I shut off my pi and when it was booting, I pressed shift and was able to open up the config.txt file (but that's about all I can do other than install a new os). I commented out the two lines that I added right before, those lines being: dtparam=i2c_arm=on dtparam=i2c1=on hoping that undoing something I did would fix it, but still no progress.

Can anyone tell me what's happening and how to fix it? Thank you in advance.

  • The first partition on the SD card is DOS/vfat formatted, meaning you should be able to access it from any computer (you must have one, since you'd need that to format the card and/or contemplate re-installing it). This is where you can put an ssh and wpa_supplicant file for incorporation after boot. It is also where cmdline.txt is. – goldilocks Aug 8 at 16:48
  • Your question is unclear (and apparently nothing to do with SSH), the (undated) tutorial is obsolete, but AFAIK should have done nothing to cause login problems. As we don't know exactly WHAT you did your only option is to restore from your backup. To enable I²C use the raspi-config menu. – Milliways Aug 9 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.