1

Following Raspberry Pi's own tutorial for setting up an access point (https://github.com/raspberrypi/documentation/blob/master/configuration/wireless/access-point.md) from a clean Raspbian Buster image with updated and upgraded packages, Raspbian crashes consistently when connecting to the access point from another computer. The access point is from a USB dongle on the Pi.

I'm obviously unable to share what's logged to the screen since the Pi becomes completely unresponsive and the only way to recover it is to pull the power and then plug it back in.

I was able to narrow down the problem by running through the same tutorial on the 2018-11-13-raspbian-stretch-lite archived Raspbian image. I followed the exact same steps with the same hardware (but without upgrading the packages!) and everything worked fine as before.

It seems the the problem is due to some updated package in the past few months, but I can't seem to narrow down exactly which one.

Has anyone else experienced something similar?

  • 'm obviously unable to share what's logged to the screen why? there's log files, there's cameras, there's pen and paper :D – Jaromanda X Aug 9 at 2:40
  • Sorry for this bad quality, but this is the best I could do: youtu.be/ES7TwySB4i8 The crash isn't saved to any of the system logs. – Zane Mountcastle Aug 9 at 22:26
  • so that video shows when another computer connects to the pi? It looked like a boot sequence of the pi - oh, wait, second viewing, i see that it isn't – Jaromanda X Aug 10 at 0:03
  • Correct. The name of the access point is MissionMule. As soon as I try to connect (time 0:01 in the video) from another computer, there's sort of kernel/memory dump. – Zane Mountcastle Aug 10 at 0:04
  • can you post the details of the USB dongle and which model pi is it – Jaromanda X Aug 10 at 0:07
0

I have had this same issue occur with the latest Lite versions of Buster, Stretch, and Jessie, on Pi 3 B+ with Edimax Dongles and onboard wifi, and Pi 2 B+ with Edimax Dongles. Something is wrong with the kernel relating to wireless drivers, but not sure how to capture the kernel panic to dig through it. I dug out an old copy of Jessie and avoided updates like the plague. There was some discussion about wireless driver issues on the Raspberry Pi forum (I think from back in March..?) but there wasn't a lot of resolution.

  • And what exactly do you suggest to solve the problem? Downgrade to an old copy of Jessie? From where and how? Its old-old stable. – Ingo Aug 13 at 15:30
  • Downgrading to 2018-11-13-raspbian-stretch-lite from downloads.raspberrypi.org/raspbian_lite/images worked for me when I don't upgrade the packages. This obviously doesn't actually fix the problem, but rolls back to a working state. It'd be great to get to the root cause of this to fix it in the newer versions of Raspbian. – Zane Mountcastle Aug 13 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.