1

I am trying to build opencv as directed for python3.7, on pi4 (2Gb Ram) with Raspbian Buster Lite, everything goes fine until I try

make -j -l 2

After 57% progress I get following error

[ 57%] Linking CXX shared library ../../lib/libopencv_core.so
/usr/bin/ld: ../../3rdparty/ippicv/ippicv_lnx/icv/lib/ia32/libippicv.a(ippcpufeatures.o): relocations in generic ELF (EM: 3)
/usr/bin/ld: ../../3rdparty/ippicv/ippicv_lnx/icv/lib/ia32/libippicv.a: error adding symbols: file in wrong format
collect2: error: ld returned 1 exit status
make[2]: *** [modules/core/CMakeFiles/opencv_core.dir/build.make:1347: lib/libopencv_core.so.4.1.1] Error 1
make[1]: *** [CMakeFiles/Makefile2:1371: modules/core/CMakeFiles/opencv_core.dir/all] Error 2

I have tried

  • installing and removing python3-opencv library
  • opencv version 4.1.1 and 3.4.5

in both scenarios error remains same.

2

Try running just make, as it's possible the Pi doesn't have enough memory to run the build on two cores. It takes longer, but it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.