1

I'm trying to install the libindi astronomy toolset on my Raspberry PI 3 uname gives me

Linux raspberrypi 4.19.58-v7+ #1245 SMP Fri Jul 12 17:25:51 BST 2019 armv7l GNU/Linux

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"

For libindi I need to pre-install some packages:

sudo apt-get install libnova-dev libcfitsio-dev libusb-1.0-0-dev zlib1g-dev libgsl-dev build-essential cmake git libjpeg-dev libcurl4-gnutls-dev libtiff-dev

It works when I install packages on my desktop under Ubuntu, but I have no luck so far on Raspberry:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libnova-dev
E: Unable to locate package libcfitsio-dev
E: Unable to locate package libgsl-dev
E: Unable to locate package libjpeg-dev
E: Unable to locate package libcurl4-gnutls-dev
E: Unable to locate package libtiff-dev

I did sudo apt update && sudo apt upgrade, but it does not help. I have seen many guides where other people get this indilib successfully installed (like here or here).

How can I get those packages on my raspi without installing other OS image like ubuntu?

UPDATE

sudo apt update works without any error

Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian buster InRelease [25.1 kB]     
Get:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0 MB]
Get:4 http://archive.raspberrypi.org/debian buster/main armhf Packages [213 kB]
Get:5 http://raspbian.raspberrypi.org/raspbian buster/contrib armhf Packages [58.7 kB]
Get:6 http://raspbian.raspberrypi.org/raspbian buster/non-free armhf Packages [103 kB]
Get:7 http://raspbian.raspberrypi.org/raspbian buster/rpi armhf Packages [1360 B]
Fetched 13.4 MB in 19s (720 kB/s)                                              
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

Content of /etc/apt/sources.list

deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

/etc/apt/sources.list.d/raspi.list

deb http://archive.raspberrypi.org/debian/ buster main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ buster main ui
  • 1
    No problem here. Do you get any errors from sudo apt update? And what is the output of apt policy libnova-dev? Please update your question with this info – Dirk Aug 13 at 20:10
  • Ditto, they're all available. Edit in the output from cat /etc/apt/sources.list and cat /etc/apt/sources.list.d/raspi.list. – goldilocks Aug 13 at 20:16
1

Okay, after running sudo apt update again I was able to install all missing packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.