0

I am using a Raspberry Pi 3 A+ with Raspbian Stretch (updated/upgraded about a month ago), connected to a Manga Screen 2: http://wiki.thing-printer.com/index.php?title=Manga_Screen_2

I have used this Raspberry Pi with a 1920x1080 desktop monitor, and also with an 800x480 5" HDMI touchscreen, and it works flawlessly with both of those. I am able to get the screen to display correctly on the Manga Screen 2, and the touches register correctly, but after setting config.txt and making a .rules file the wifi is magically disabled and I am out of ideas.

My config.txt is unmodified except for the hdmi configuration that the wiki for this screen specifies. wpa_supplicant contains the correct information, since it is unchanged and was working with a different screen just a few hours ago.

When I scan for wireless networks with iwlist wlan0 scan, I am able to see all the ones I should, including the one it was connected to before I switched screens. However, hovering over the wifi icon shows "wlan0 not associated" and ifup wlan0 tells me "unknown interface wlan0."

This fix did nothing: RasPi 3 - wlan0 not associated

I have tried 4 different Raspberry Pi 3 A+'s, as well as 3 different power supplies, and nothing has made a difference yet.

Any thoughts are appreciated. Thanks.

Edit 1: I believe the problem is caused by this line in config.txt:

hdmi_timings=1080 1 100 10 60 1920 1 4 2 4 0 0 0 60 0 144000000 3

When I comment out my changes to config.txt and connect the pi to an external monitor, the wifi connects with absolutely no issue. I need to read more about what that line actually does.

0

Okay, I'm not sure why exactly this was causing an issue or why this is the fix, but I successfully restored my wifi connection. If anyone knows why this bug exists, I would love to know.

The line hdmi_timings=1080 1 100 10 60 1920 1 4 2 4 0 0 0 60 0 144000000 3, paired with hdmi_mode=87 allows the user to specify a custom HDMI connection. The parameter of concern here is the pixel_freq or pixel clock frequency (the second to last number), which the manufacturer says to use 144 MHz (144000000). Official Raspberry Pi documentation says that this number should be horizontal resolution * vertical resolution * refresh rate, which is 1920x1080x60 for me. This comes out to 124416000, not 144 MHz even.

Replacing the 144 MHz value with my number restored the wifi connection:

hdmi_timings=1080 1 100 10 60 1920 1 4 2 4 0 0 0 60 0 124416000 3 👍

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.