1

I have a Xerox phaser 3020 laser printer and I want to set it up with my raspberrypi 3B running

$ lsb_release -rd
Description:    Raspbian GNU/Linux 10 (buster)
Release:    10
$ uname -a
Linux raspberrypi 4.19.63-v7+ #1249 SMP Thu Aug 1 16:26:30 BST 2019 armv7l GNU/Linux

Current situation:

Current situation

I have the driver from the manufacturer but the arm architecture support is kind of vague to me because they have something in uld/arm folder in the driver software but can't figure it out how or what to do with it as the install.sh script fails for the RPI but works ok on x86_64 based GNU/Linux systems(tested already). So far I have provided the 3020 models's ppd file existing in the uld/noarch/share/ppd and copied the uld/arm/rastertospl to /usr/lib/cups/filter/ directory but what about the rest of the files in the uld/arm/ folder?

$ ls
gettext  libsane-smfp.so.1.0.1  libscmssc.so  pstosecps  rastertospl  smfpnetdiscovery  usbresetter

because I am still getting the error in the test page saying

SPL ERROR - please use the proper driver
    POSITION : 0x0 (0)
    SYSTEM : h6fwsim/xl_op
    LINE : 217
    VERSION : SPL 5.90 05-15-2014
    ERROR CODE : 11-1113

And the cups error log.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.