0

On my Raspbian Buster Lite (slightly customized) at boot I notice the Login Service fails to start several times:

[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.
[  OK  ] Stopped Login Service.
         Starting Login Service...
[  OK  ] Started LSB: Switch to ondemand cpu governor (unless shift key is pressed).
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.
[  OK  ] Stopped Login Service.
         Starting Login Service...
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.
[  OK  ] Stopped Login Service.
         Starting Login Service...
[  OK  ] Started Initial setup.
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.
[  OK  ] Stopped Login Service.
         Starting Login Service...
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.
[  OK  ] Stopped Login Service.
[FAILED] Failed to start Login Service.
See 'systemctl status systemd-logind.service' for details.

systemctl status systemd-logind.service outputs:

● systemd-logind.service - Login Service
   Loaded: loaded (/lib/systemd/system/systemd-logind.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2019-08-18 21:22:15 CEST; 3min 8s ago
     Docs: man:systemd-logind.service(8)
           man:logind.conf(5)
           https://www.freedesktop.org/wiki/Software/systemd/logind
           https://www.freedesktop.org/wiki/Software/systemd/multiseat
  Process: 409 ExecStart=/lib/systemd/systemd-logind (code=exited, status=1/FAILURE)
 Main PID: 409 (code=exited, status=1/FAILURE)

Aug 18 21:22:15 pi systemd[1]: systemd-logind.service: Service has no hold-off time (RestartSec=0), scheduling restart.
Aug 18 21:22:15 pi systemd[1]: systemd-logind.service: Scheduled restart job, restart counter is at 5.
Aug 18 21:22:15 pi systemd[1]: Stopped Login Service.
Aug 18 21:22:15 pi systemd[1]: systemd-logind.service: Start request repeated too quickly.
Aug 18 21:22:15 pi systemd[1]: systemd-logind.service: Failed with result 'exit-code'.
Aug 18 21:22:15 pi systemd[1]: Failed to start Login Service.

but I don't see anything about the cause of the failure. Where should I look to understand why it fails?

  • Press CTRL+ALT+F2 to get a console login. Login as pi (password=raspberry unless you've changed it). When the bash prompt appears run cd /home/pi; sudo chown -R pi.pi *; sudo reboot;. – Dougie Aug 19 at 16:01
  • I think there's a typo: sudo chown -R pi:pi *. Anyway, this is one of the last commands I run in my script to customize Raspian Lite. So my home directory is already owned by pi:pi – Mark Aug 20 at 16:56
-1

I have had this problem before. The way I fixed it was:

  1. If you can access shell proceed to 1A. If not proceed to 1B
    1A. Enter sudo shutdown then go to 1B
    1B. Unplug the rpi
  2. Plug back in
  3. Hold shift
  4. Select desired os
  5. Select install THIS WILL ERASE ALL DATA
  6. Confirm.
  7. Wait for install to complete.
  8. Select an os to boot to.
  • That only works with NOOBS and is just a little bit destructive of EVERYTHING you've ever done on the SDCard you're booting from. – Dougie Aug 19 at 15:59
  • Well when this happened to me and it was the only option. – Jonathan Aug 19 at 16:11
  • According to here it's the only way: raspberrypi.org/forums/viewtopic.php?t=220825 – Jonathan Aug 28 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.