0

I found some posts that walk you through the installation but they are very old and don’t work anymore. I tried to install the oracle java for Arm Linux and then modify the IB installation script to point to the newly installed version of java but when running the script is says that it is corrupted.

I was following this guide: Trading on Raspberry Pi with Ubuntu 16.04.

Java version installed 1.8.0_65

After installing java the guide says to uncomment this line:

#INSTALL4J_JAVA_HOME_OVERRIDE=

and point it to the installed java.

INSTALL4J_JAVA_HOME_OVERRIDE= /usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/bin/java

After doing this the installer gives me this message

gzip: sfx_archive.tar.gz: not in gzip format I am sorry, but the installer file seems to be corrupted. If you downloaded that file please try it again. If you transfer that file with ftp please make sure that you are using binary mode.

The installer I am using is: ibgateway-stable-standalone-linux-x86.sh

Please help

5
  • What is interactive brokers IB gateway?
    – Ingo
    Aug 19 '19 at 23:07
  • @Ingo an application that has to be constantly running in order to access the interactive brokers api
    – Joan Arau
    Aug 19 '19 at 23:58
  • But it MUST not run on a Raspberry Pi, right? Does it need Java? What script exactly do you use?
    – Ingo
    Aug 20 '19 at 9:04
  • If there is no way to run it on the pi I would have to buy a more expensive linux machine to do the job I originally bought the pi for... would be nice if I could get it to run on the pi
    – Joan Arau
    Aug 20 '19 at 9:48
  • Thank you, I deleted my comments and edited the question
    – Joan Arau
    Aug 20 '19 at 11:38
0

Make sure you edit the shell script in binary mode! It sounds like you may have edited it as plain text. (eg. use vi -b)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.