0

My raspberry pi is 3 Model B v 1.2.

I have changed the i2c baud rate to

The configuration in my raspberry pi are

# cat /boot/config.txt
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on,i2c_arm_baudrate=10000
dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

enable_uart=1

#core_freq=250
dtoverlay=w1-gpio

I am following the tutorial https://www.waveshare.com/wiki/Raspberry_Pi_Tutorial_Series:_I2C

I see that there are four address here.

root@raspberrypi:/home/pi# i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: 50 -- 52 -- 54 -- 56 -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

When I remove the vcc connection of this EEPROM chip, I see that the i2detect shows nothing. But when I plug it back, it says four addresses. Why there are four addresses?

When I do

# i2cget -y 1 0x50
0xff

But when I do this again

# i2cget -y 1 0x50
Error: Read failed
14
  • My comments to the following question might help: raspberrypi.stackexchange.com/questions/101598/….
    – tlfong01
    Aug 20, 2019 at 8:45
  • It doesn't help since I can't even write anything on the address - 0x50. For e.g. - i2cset -y 1 0x50 0x00 0x40 Aug 21, 2019 at 5:28
  • Ah, let me see. My command "i2cdetect -y 1" gives only one address, but yours gives 4. So first thing first is to solve the too-many-fake-addresses problem. Have you tried the suggestions in my comments? Of course I can try to reproduce your fake addresses by (1) increasing I2C speed higher and higher, until I also get three more fake addresses, (2) making my connecting wires longer and longer, until I also get fake addresses. But that does not solve your problem. So perhaps you can decrease I2C speed and shorten the wires, to see if you can reproduce my no fake address situation. :)
    – tlfong01
    Aug 21, 2019 at 5:47
  • I am giving 3.3Volts to this sensor, is that fine? Aug 21, 2019 at 6:13
  • yes, that is fine.
    – tlfong01
    Aug 21, 2019 at 6:25

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.