9

Surroundings

Problem

VNC connection remote desktop error: cannot currently show the desktop, I have enabled VNC and boot desktop automatic login option when booting, but still can't connect to the desktop, what other options do I need to set?

Attached: SSH everything is normal

error message

8

Yes, in addition to the above two operations must also set the resolution, the specific location in Advanced Options > Resolution, select the appropriate resolution.

  1. first step
  2. Second step
  3. third step
2
  • This is not working for me. :( – DaveTheMinion Dec 24 '19 at 23:33
  • not working for me, raspbian lite version – Inzamam Malik Mar 18 '20 at 22:38
4

I installed on the smart card the Debian VERSION="10 (buster)". There is no Display connected to the Raspberry. I'm connected it only through it's Ethernet (UTP-cable), and the wifi module is disabled. I edited as sudo the /boot/config.txt file to disabble the wifi loading on boot.

# wifi off / dissable
# change on 10-08-2019
dtoverlay=pi3-disable-wifi

I gave a try to connect on it with VNC from another Rpi, and I got the same Message:
Cannot currently show the desktop

I logged through ssh on that computer and started the desktop:

ssh user@ipadress
# where the user is
echo $USER
# where the ipadress is
ip a | grep -o "[1-9].*/24" | sed 's/\/.*//g'

after I logged in into that remote computer

sudo startx

And it worked!

The remote desktop voila!

1
  • 2
    Most of this is irrelevant! Obviously, if you don't have a desktop, VNC can't display it. – Milliways Jan 19 '20 at 23:02
1

Disable the GL Experimental Desktop - I also then set the screen resolution in raspi-config. I tried everything else and this was the only thing that worked for me.

1
  • This worked for me also - without disabling the GL desktop it was stuck in a low-res 4:3 mode – Brian Burns Oct 27 '20 at 15:40
0

Your pi seems not running a graphical desktop. Since remote access with SSH is working, an alternative solution is to create a virtual desktop using the VNC Server and connect to it afterwards.

The raspberrypi.org provides a doc for such connection: with SSH, run vncserver and make note of the IP address/display number. Then you can use it for the VNC connection.

With my headless pi as an example:enter image description here

The IP address/display number for the VNC connection is in the Connectivity section. BTW I hide the Security information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.