I can't connect to my local NAS from my Raspberry Pi, and yet, on my Mac I can using the old Cmd+K.

So far, I've tried several options, including :

  • sudo mount -t cifs -o username=USERNAME,password=PASSWORD // 192.168.X.X /mnt/ which tries to connect as root;
  • sudo mount -t cifs -o username=USERNAME,password=PASSWORD // 192.168.X.X/USERNAME /mnt/ which does the same, except with my private user (that's the point!);
  • in sudo nano /etc/fstab, I've tried //192.168.X.X/USERNAME /mnt/ cifs username=USERNAME,password=PASSWORD 0 0 (also tried using the credentials in a file inside my /home/PI_USER/ directory) and changing //192.168.X.X/USERNAME to //192.168.X.X:/USERNAME;

Encountered errors

I am getting any of those depending of the command :

  • Unable to find suitable address
  • mount error: could not resolve address for 192.168.X.X:: Unknown error (so helpful!)
  • or simply listing a the Usage for the mount command

Whenever I run sudo tail -f /var/log/kern.log, I get :

  • CIFS VFS: Error connecting to socket. Aborting operation.
  • CIFS VFS: cifs_mount failed w/ retur code = -113

Notes :

  • I've tried rebooting as well as sudo mount -a to try to connect;
  • I am running on a fresh installation of a PI with samba, samba-client and samba-common-bin installed;
  • I have double, triple and quadruple checked my login information and paths;
  • Contrary to several tutorials I've found, I do not need to create a NAS server from the Pi, I need it to be a client;
  • I can ping my server with 0% packet loss
  • 1
    -f is fake mount. You probably meant -t. Is that a typo in the question? – Ljm Dullaart Aug 21 '19 at 16:37
  • @LjmDullaart yes, it was simply a typo, just fixed it. I am still however getting error messages. – davewoodhall Aug 21 '19 at 17:21
  • 1
    You say you installes samba-client; in my installations that would be smbclient. Did you install cifs-utils as well? – Ljm Dullaart Aug 21 '19 at 17:50
  • Is it a (relatively) new NAS? Do you know which version of CIFS/SMB the NAS is running? Could you try adding that version number to the fstab-line? //isengard /media/isengard cifs uid=0,credentials=/home/tim/.smb,iocharset=utf8,vers=3.0,noperm 0 0 – Ljm Dullaart Aug 21 '19 at 17:54
  • It would help if you connected the commands and the error messages more directly. As in sudo mount -t etc gives the following error message: .... – Ljm Dullaart Aug 21 '19 at 17:55

samba-client is a so-called virtual package. From the FAQ:

Debian GNU/Linux FAQ

6.8 What is a Virtual Package?

A virtual package is a generic name that applies to any one of a group of packages, all of which provide similar basic functionality. For example, both the tin and trn programs are news readers, and should therefore satisfy any dependency of a program that required a news reader on a system, in order to work or to be useful. They are therefore both said to provide the "virtual package" called news-reader.

In this case, smbclient provides the virtual packagesamba-client. However, installing samba-client will not install smbclient as it dependency.

In this case, installing the real package (smbclient) provides the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.