0

I found several topics which describe the same issue as I have but none of the solutions worked for me so far. So on boot, the raspberry asks for a username and password (what it shouldn't) and when I enter pi/raspberry the screen quickly gets black and then the login re-appears. This happened after I upgraded my Jessie to Stretch but if I'm correct, rebooting worked a few times.

I can still login through SSH so my credentials are correct. As far as I can tell I only added one line in my .profile which I reverted back already - without change.

The only hint I got so far are the following lines from my .xsession-errors

dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
/usr/bin/x-session-manager: 33: exec: /usr/bin/lxsession: not found

I'm not super experienced with Linux so I'm not sure if just re-installing LXDE would be the right thing here.

3
  • If you do an unsupported upgrade from one obsolete OS to another expert problems. Do a fresh install – Milliways Aug 21 '19 at 22:42
  • At what point did I do an unsupported update? – po.pe Aug 22 '19 at 6:04
  • Anyone with an idea? – po.pe Aug 26 '19 at 14:05
0

I add the same issue. Looks like installing lxsession worked for me.

2
  • 1
    What does "looks like" mean? And what do you add to the issue? – Dmitry Grigoryev Apr 26 '20 at 12:57
  • Well, I had the exact same issue. "Looks like" mean that so far it solved the issue. But I still have no idea why it solved it. So maybe there is a more efficient way of solving it. – Lucas May 1 '20 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.