1

Yes, I am aware that similar questions have been asked before on this StackExchange but almost all of those are old and don't seem to be working for me.

After googling around I found that things have been changed ever since rasipbian moved to NetworkManager to manage the network stuff instead of good old ifup/ifdown.

I've also tried to navigate through the documentation of NetworkManager but to no avail.

I just want my pi to have simultaneous access to 2 networks:

  • Using the ethernet wire.
  • Using the onboard WiFi.

Both these connections must work at the same time so that if I host any application to ip 0.0.0.0, I can access that application from either of the network's devices by using the corresponding IP of pi on that network.

Let me know if I need to be more specific about somethings. :)

Thanks

  • Raspbian has NOT moved to NetworkManager! See How to set up networking/WiFi. I see no question here. – Milliways Aug 22 '19 at 1:32
  • Yes, I found too many os version specific network things out of date before I started to learn. I am waiting for Rpi4B and buster to settle down. – tlfong01 Aug 22 '19 at 1:33
  • @Milliways That answer doesn't tell me anything about how to set up simultaneous access to both ethernet and wifi :/ – Curious66 Aug 22 '19 at 1:39
  • 1
    If fact the answer does - it tells you how to do most things in dhcpcd; it may not answer what you want to do, but it is unclear what this is - more detail needed. What does "if I host any application to port 0.0.0.0" mean? – Milliways Aug 22 '19 at 1:42
  • @Milliways My bad, I meant to say IP 0.0.0.0, not the port. Sorry about that – Curious66 Aug 22 '19 at 1:54
0

This solved my problems or is this just my setup?

With a prebuilt custom version of Raspbian Buster on Pi 3 the dhclient was a problem interfering with dhcpcd so first had to remove the isc-dhcp-common and isc-dhcp-client packages.

Then /etc/network/interfaces with the wpa-conf for /etc/wpa_supplicant/wpa_supplicant.conf and desired /etc/dhcpcd.conf settings finally worked.

There are probably other ways to fix the problem like fiddling with the networkd just not as easy.

Update: I thought my problems were fixed except they returned. Now the wifi wouldn't connect when the HDMI was plugged with the notice of "no carrier". The wifi worked as expected running headless with no changes except removing the HDMI. So went back to a custom build of raspbian stretch.

Update2: Got Buster wifi to work with Raspberry Pi 3b by editing /boot/config.txt HDMI section. I added hdmi_ignore_cec=1 and I think that fixed the wifi. I also changed the other hdmi settings to force tv mode HDMI instead of monitor mode and also changed the hdmi cable so not positive what actually worked. Now wifi works with headless and with HDMI running my TV. Very wierd.

| improve this answer | |
  • Are you the Original Poster of the question? – Ingo Apr 16 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.