0

I have Rapsberry pi 4B with 2GB of RAM. After some time I powered up Pi but not video output was shown. So I connected via ssh but there is no :0:

 16:02:32 up 13 min,  2 users,  load average: 0.00, 0.00, 0.00
USER     TTY      FROM             LOGIN@   IDLE   JCPU   PCPU WHAT
pi       tty1     -                15:48   14:35   0.13s  0.09s -bash
pi       pts/0    xxxxx 15:48    0.00s  1.25s  0.01s w

I tried fresh installation of raspbian buster bot it didn't help. In /var/log there is a log called Xorg.0.log. In the end of this file I can find these messages:

Fatal server error:
[   111.497] (EE) no screens found(EE) 
[   111.498] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   111.498] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   111.499] (EE) 
[   111.499] (EE) Server terminated with error (1). Closing log file.

Same messages are available when sudo startx command is called but inside dmesg I can't find anything related to the GPU.

Does anyone know what to do with it? I don't have connected anything special, just HDMI and it worked already, that's the weird thing on it.

EDIT: So it turned out, that my HDMI->VGA converter stopped working with RPI (with computer works well) and after reboot with connected HDMI monitor I can see

pi tty7 :0 16:41 3:32 1.36s 0.20s /usr/bin/lxsess

in w command. Problem is that I need :0 DISPLAY even if HDMI is not currently connected.

  • You will need to include the details of how and what display is connected to the Pi. – goldilocks Aug 22 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.