1

So I previously setup my ad hoc network on my prior Raspberry Pi 3B by adding these lines to my /etc/network/interfaces file:

auto wlan0 

iface wlan0 inet static   
address 10.2.1.1   
netmask 255.255.255.0   
wireless-channel 1   
wireless-essid PiAdHocNetwork   
wireless-mode ad-hoc

I just tried this same thing on my new Pi 4 running Buster and it did not work. I setup two Raspberry Pis using this method and tried to ping between them with no luck. How do I setup an ad hoc network on the Pi 4 with Buster? I can't find any examples and I'm not sure the syntax in the .conf or wpa_supplicant files....Also would like to know how to control TX power. Thanks!

1

I haven't found any important differences between the wifi devices on RPi 3B, RPi 3B+ (yes, that supports 5 GHz) and RPi 4B. All my wifi setups where upstream compatible.

You are using Debian ifupdown. It may be possible that this old style networking get more and more out of the focus from the developers with newer versions of the operating system. In addition, on Raspbian the default networking system is dhcpcd but that seems not to be able to setup an ad-hoc network.

You may have a look at different setup examples using systemd-networkd on How to setup an unprotected Ad Hoc (IBSS) Network and if possible with WPA encryption? I have just tested them on a Raspberry Pi 4B with Raspbian Buster Light without any problems. It works.

0

I have little experience of Ad hoc networking, and am unsure if the on-board hardware supports it.

The settings you have tried should work if you disable dhcpcd

sudo disable dhcpcd

Then reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.