0

I can use sudo vncserver-x11-serviced & to start a VNC Server as a daemon.

I need to execute this command whenever I boot or reboot Raspberry Pi.

From https://www.realvnc.com/en/connect/docs/man/vncserver-x11-serviced.html, I learned that sudo update-rc.d vncserver-x11-serviced defaults is the command.

However, vncserver-x11-serviced is in /usr/bin, so I made a symbolic link in /etc/init.d with sudo ln -s /usr/bin/vncserver-x11-serviced /init.d/vncserver-x11-serviced

Then, I executed sudo update-rc.d vncserver-x11-serviced defaults as is written in the webpage.

However, when I try to access the Raspberry Pi RealVNC server using RealVNC Viewer, I have the error message.

What might be wrong?

error message

  • 1
    Which OS/Distro do you use? Raspbian uses systemd, so you may be using the wrong command. The correct one for Raspbian starts with sudo systemctl enable ... as listed on the RealVNC web page you link to. – Dirk Aug 22 at 22:04
  • @Dirk: I use Raspibian, I thought it's Debian based (from the book Raspberry Pi Cookbook). So, I tried update-rc.d. – prosseek Aug 22 at 23:34
  • Debian also uses systemd (starting with Jessie). You're apparently using outdated information... – Dirk Aug 22 at 23:48
  • If you are using Raspbian just enable in raspi-config – Milliways Aug 23 at 3:38
  • You should not use scripts in /etc/init.d/ anymore: raspberrypi.stackexchange.com/a/101852/79866 – Ingo Aug 23 at 8:21
1

sudo systemctl start vncserver-x11-serviced.service solved this issue. I downloaded VNCReal server without knowing Raspberry Pi already has it. Reinstallation of Raspibian and execution of the systemctl solved this issue.

I found that sudo raspi-config has `interfacing options' to turn on VNC too. https://www.realvnc.com/en/connect/docs/raspberry-pi.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.