3

I formatted my SD card to fat32 using GParted and copied all the files from the official NOOBS Lite download: https://www.raspberrypi.org/downloads/noobs/. I unzipped using unzip command on the terminal. When I turn on the rainbow appears and the Pi gets stuck there. Red LED is on, green turned off after a few seconds. Don't know if I did something wrong or my card is broken. Appreciate your help.

  • rainbow usually means under voltage – tlfong01 Aug 23 at 0:51
  • Rainbow with a good power supply on a RPi4 is 100% bound to be an SDCard that doesn't have the RPi4 kernel and firmware. – Dougie Aug 23 at 9:00
2

Feel so dumb. Tried connecting to the other HDMI port and the image appeared, it was actually booting but showing the rainbow through that port. How do I switch from HDMI port 1 to 2 to show as default? I have to force it a little to use HDMI port 1 as it is right next to the power cable. Also, now I'm getting another error when I try to flash Raspbian full:

Error creating file system
Mkfs.fat: warning lowercase labels might not work properly with DOS or Windows
Mkfs.fat: too few blocks for viable system
Mkfs.fat: 3.0.26 (2014-03-07)
  • You answered the question but asked a new question. How to answer to an answer? You should make a new question. – Ingo Aug 23 at 17:01
0

The Boot Problems Sticky contains detailed troubleshooting steps.

Using NOOBS just makes fault finding harder.

The rainbow screen is due to missing (or obsolete) firmware.

I suggest you use Etcher to install Raspbian to a SD Card (like the vast bulk of us).

If you REALLY want to install NOOBS, make sure you have the LATEST version and follow the Foundation instructions =>

Visit the SD Association’s website and download SD Formatter for Windows or Mac.

-2

I ran into the same problem while working on my project. It seems like a low voltage problem so make sure the power supply has minimum of 2A Output and that should fix the rainbow screen problem.

  • 1
    The rainbow screen is unrelated to low voltage it indicates missing or obsolete boot files. – Milliways Aug 23 at 3:28
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Milliways Aug 23 at 7:10
  • @Milliways "Immediately after displaying the splash screen, the PI starts consuming a little more current. If the PI resets at that moment, it is an indication that the power supply isn't able to deliver the full current your PI requires..." elinux.org/R-Pi_Troubleshooting#Coloured_splash_screen Of course this does not mean stuck on the rainbow screen. – goldilocks Aug 23 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.